AnsweredAssumed Answered

Computer freezes during AMD driver detect

Question asked by bashan755 on Mar 11, 2020
Latest reply on Mar 24, 2020 by r3v3ng3r

I have a newly built rig as of last year. Win10 (now at v1909), Ryzen 3700X, 32GB, AMD RX580 8G (Sapphire Nitro+), and Seasonic 620W PSU.Everything is running at stock speeds. Everything works except I cannot update the Radeon drivers. I have tried dozens of drivers, old and new and when the driver hits the detect hardware stage (just after extracting the files) the whole computer freezes and then resets. There is no BSOD. It happens every time, even in safe mode. I tried AMD cleanuputility, DDU, AND a full Windows reinstall from scratch, etc. The only driver I have that works came with Windows and it is version 23.20.832.0 (3/3/2018). I have been playing a bunch of games with it and everything works fine. The last game I played through was Rise of the Tomb Raider. So clearly the card works. I never have any game issues or crashes. There are no yellow flags in the device manager, and The device mgr "Update drivers" option says the best ones are already installed


Now I want to play Wolfenstein II The New colossus and the game won't even run despite the machine being fully capable. Of course, the first troubleshooting step is check the drivers. Well I can't do that.


I suspect that the default driver doesn't come with the full vulkan stuff and I think the game needs it. When I run the game directly from the Steam folder it says "The code execution cannot proceed because vulkan-1.dll was not found..." I've wiped and reinstalled the game.

AMD Radeon Settings (2018.0303.2240.40774) show up in Apps & Features and the desktop context menu but the app won't run.

#1
What I am looking for at this point is a direct download or a way to run just Wattman so I can maybe underclock the card and see if that will get the driver installed. I can't find a download and I think they're included in the adrenalin pkg.

#2
An alternative might be to manually install a subset of the drivers without a detection phase. I can't find any information about that, but the AMD minimal driver download also crashes the PC.

Outcomes