AnsweredAssumed Answered

unable to get installer file to launch the requested page

Question asked by bfs_tao on Mar 11, 2020
Latest reply on Jun 14, 2020 by dip03

I have the 17.1.1 version installed for the Asus RoG Strix Rx 570 4gb card. And the current update is 20.2.2. Every time i try to express install it doesnt let me do it. Ive also tried manually download the update from AMD site itself but got some other issues with the installations that cause me to retract back to 17.1.1. As you know Warzone requires the newest update to run otherwise you get a directx error. No code just an error untill you got the latest gpu driver installed.

 

The issue i have with the manual installation of 20.2.2 is my cursor keeps on getting that loading/thinking icon and most of my games dont work. Warzone loads goes in and after 2/3 minutes it closes/crashes. It completely close like as if you press Alt+F4. Apex does not work. It verifies the game then starts "repair" in a few sec till 40% then it stops. After 30min of leaving it to finish "repair" while still sitting on 40% it stops completely and starts to redownload. 

So now that i retracted back to 17.1.1 everything seems to be working fine, however i cant update my driver via the Radeon settings. Yesterday i tried and it didnt even gave me an update to install. It kept on giving me the currently installed 17.1.1, unlike it does today which gives me the tiltled error of unable to get installer.

I see some suggest using DDU (Display drivers Uninstaller) which is a program to completely remove any and all traces of amd/nvidia drivers/register keys etc etc. 

Attachments

Outcomes