dypol

Thread_Stuck_In_Device_Driver BSOD on a laptop with Radeon RX560

Discussion created by dypol on Mar 8, 2020

Hello,

 

I have some serious issues with my laptop and it seems that there may be a problem with the AMD Radeon GPU.

 

It all started a few days ago when my laptop crashed when I was gaming. Game stopped on a single frame, stuttering sound in a constant loop was audible in my headphones and a hard reset was necessary. After this I found out that Windows does not boot. System repair and restore didn't work either, so after backuping my personal files I reinstalled the system using bootable USB flash drive.

 

The system was installed succesfully and I proceeded to install drivers using Lenovo utility called Lenovo Vantage. During this process the system crashed to BSOD with error message 'THREAD_STUCK_IN_DEVICE_DRIVER'. After this the system 'repaired itself' discarding some updates. I opened the device manager and found that drivers for Radeon RX560 GPU were not installed properly and probably they were causing the problem. An attempt to update the drivers in device manager triggered the BSOD 'thread stuck...' crash again. Letting Windows Update download drivers on its own also resulted in same crash. In the dump file the driver causing the problem is identified as atikmdag.sys

 

I also downloaded some older GPU drivers for my laptop from Lenovo support site and tried installing them after clean installing Windows from flash drive again, but got the same 'thread stuck...' error. Finally I tried to install the newest Adrenalin 2020 20.2.2 drivers I found on the AMD website, also after reinstalling the system - with the very same negative outcome.

 

The laptop works just fine as long as I do not try to install and drivers for the RX560.

 

I'm attaching minidump file. What is going on? Is my GPU dead?

 

Hardware: Lenovo Ideapad 720-15IKB with Intel i5-8250U CPU, Radeon RX560 GPU, 8GB RAM, 256GB SSD drive, Win 10 Home 64bit v. 1909

Attachments

Outcomes