jacobb_l

My Computer is having constant atikmpag.sys Errors, but I Cannot Find the File Anywhere on my PC. I'm in major need of help.

Discussion created by jacobb_l on Mar 5, 2020

Specs: https://pcpartpicker.com/list/Q9sRK4 

 

   Hello everyone. I am a novice desktop user, and have built my first rig as of December 30th, 2019. It seemed to work perfectly fine for less than a month, but now is experiencing some unbearably frustrating issues, and I can't seem to figure it out. I'm trying my best to fix this without spending extra money, and I can't deduct whether this is software or hardware, and what unit, drivers, etc. need attention.

 

Symptoms:

-PC randomly loses display without warning, first visuals then audio and windows (10) connection (may be in a game or not)

-When display is lost, the screen will turn a color while crashing usually related to the current colors being processed by the GPU, but sometimes are unrelated

-When display is lost and windows fails, the PC power and motherboard lights remain active, as well as the fans running

-Fans have become really noticeable in volume, but the PC doesn't seem to be overheating

-Livekernelevent 41 (63) is found in event viewer

-One specific HID is said to not start in device manager, but it doesn't seem to matter

-After crashing 2-3 times, the PC will work just fine for however long I want, or will crash after a VERY long time in use

-Crashes in sleep mode

-DMP files read atikmpag.sys errors, HOWEVER NO SUCH FILE (atikmpag.sys) CAN BE FOUND IN THE DRIVERS FOLDER OF SYSTEM32, AS WELL AS NO ATI DIRECTORY FOLDER IN (C:\). => I tried to replace the atikmpag.sys file

-NO BSOD's

 

Attempted fixes that I can remember (no success, in no particular order)

-Changing power settings

-Turning off fast startup

-DDU and reinstalling GPU drivers

-Trying earlier versions of drivers

-Updating drivers

-Updating windows

-Installing respective drivers for PC components

-Cleaning and securing cables

-Testing games in safemode 

-Making sure I have HID drivers

-Acquiring a surge protector

-System file checker

-Chkdsk for the HDD

-Cold booting and draining residual power from the motherboard before booting

-Changing link states in BIOS and power settings

-Updating BIOS

-Running Ubuntu

-Windows memory checker

-Crystal disk infor

-Malware bytes

-Resetting the entire PC twice, once with and the other without keeping local files

 

Fixes or methods to still try that I've seen:

-Memtest86 

-Replacing atikmpag.sys

-Replacing parts and testing performance

-Stress testing

 

Most recent dump:

 

VIDEO_ENGINE_TIMEOUT_DETECTED (141)
One of the the display engines failed to respond in timely fashion.
(This code can never be used for a real bugcheck.)
Arguments:
Arg1: ffffdd0defcdc010, Optional pointer to internal TDR recovery context (TDR_RECOVERY_CONTEXT).
Arg2: fffff80235f509f0, The pointer into responsible device driver module (e.g owner tag).
Arg3: 0000000000000000, The secondary driver specific bucketing key.
Arg4: 0000000000000000, Optional internal context dependent data.

Debugging Details:
------------------

Unable to load image atikmpag.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for atikmpag.sys

KEY_VALUES_STRING: 1


PROCESSES_ANALYSIS: 1

SERVICE_ANALYSIS: 1

STACKHASH_ANALYSIS: 1

TIMELINE_ANALYSIS: 1


DUMP_CLASS: 1

DUMP_QUALIFIER: 400

BUILD_VERSION_STRING: 10.0.18362.693 (WinBuild.160101.0800)

DUMP_TYPE: 2

BUGCHECK_P1: ffffdd0defcdc010

BUGCHECK_P2: fffff80235f509f0

BUGCHECK_P3: 0

BUGCHECK_P4: 0

FAULTING_IP:
atikmpag+109f0
fffff802`35f509f0 ?? ???

DEFAULT_BUCKET_ID: GRAPHICS_DRIVER_ENGINE_TIMEOUT

TAG_NOT_DEFINED_202b: *** Unknown TAG in analysis list 202b


CPU_COUNT: c

CPU_MHZ: d42

CPU_VENDOR: AuthenticAMD

CPU_FAMILY: 17

CPU_MODEL: 8

CPU_STEPPING: 2

BUGCHECK_STR: 0x141

PROCESS_NAME: System

CURRENT_IRQL: 0

ANALYSIS_SESSION_HOST: DESKTOP-ECS7F4C

ANALYSIS_SESSION_TIME: 03-05-2020 19:54:56.0470

ANALYSIS_VERSION: 10.0.18362.1 x86fre

STACK_TEXT:
ffff8b03`5af0e460 fffff802`364605cf : ffffdd0d`efcdc010 ffff8b03`5af0e600 00000000`000041c0 ffffdd0d`f1364050 : watchdog!WdDbgReportRecreate+0x116
ffff8b03`5af0e4b0 fffff802`3645efb8 : ffffdd0d`00000000 ffff8e02`de5eb1d0 00000000`00000000 00000000`000041c0 : dxgkrnl!TdrUpdateDbgReport+0x10f
ffff8b03`5af0e500 fffff802`360afed9 : ffffdd0d`ecf18000 ffffdd0d`ecf18060 ffffdd0d`efcdc010 ffffdd0d`ecf18000 : dxgkrnl!TdrCollectDbgInfoStage1+0x2d8
ffff8b03`5af0e640 fffff802`3614a27e : ffffdd0d`ecf18000 00000000`00000000 00000000`00000001 ffffdd0d`ecf18001 : dxgmms2!VidSchiResetEngine+0x31d
ffff8b03`5af0e930 fffff802`36121eff : ffffdd0d`e8920000 00000000`00000001 ffffdd0d`00000000 00000000`00000000 : dxgmms2!VidSchiResetEngines+0xc2
ffff8b03`5af0e980 fffff802`360fa1d4 : 00000000`00000102 00000000`00002175 00000000`00989680 00000000`00000200 : dxgmms2!VidSchiCheckHwProgress+0x27cff
ffff8b03`5af0e9f0 fffff802`36088786 : ffffdd0d`f0c0eb60 ffffdd0d`e8920000 ffff8b03`5af0eb19 00000000`00989680 : dxgmms2!VidSchiWaitForSchedulerEvents+0x354
ffff8b03`5af0eac0 fffff802`36109990 : ffffdd0d`f0bd8b00 ffffdd0d`e8920000 ffffdd0d`f0bd8b20 ffffdd0d`f0c079a0 : dxgmms2!VidSchiScheduleCommandToRun+0x2c6
ffff8b03`5af0eb80 fffff802`3610994a : ffffdd0d`e8920400 fffff802`36109880 ffffdd0d`e8920000 00000000`00000000 : dxgmms2!VidSchiRun_PriorityTable+0x30
ffff8b03`5af0ebd0 fffff802`2686bce5 : ffffdd0d`e89cb680 fffff802`00000001 ffffdd0d`e8920000 00000067`b4bbbdff : dxgmms2!VidSchiWorkerThread+0xca
ffff8b03`5af0ec10 fffff802`269c99ca : ffffb500`900c0180 ffffdd0d`e89cb680 fffff802`2686bc90 00650074`00730079 : nt!PspSystemThreadStartup+0x55
ffff8b03`5af0ec60 00000000`00000000 : ffff8b03`5af0f000 ffff8b03`5af09000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x2a


THREAD_SHA1_HASH_MOD_FUNC: 75f6463edf1de3bc7b91052b8770e1d61b5e8b3b

THREAD_SHA1_HASH_MOD_FUNC_OFFSET: c160b27b2e38f480bbd609ae51e3983fb1dbc241

THREAD_SHA1_HASH_MOD: 88e0e3feeb4365444d31cbb58397c8841fe72ae6

FOLLOWUP_IP:
atikmpag+109f0
fffff802`35f509f0 ?? ???

SYMBOL_NAME: atikmpag+109f0

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: atikmpag

IMAGE_NAME: atikmpag.sys

DEBUG_FLR_IMAGE_TIMESTAMP: 5e599e3e

STACK_COMMAND: .thread ; .cxr ; kb

FAILURE_BUCKET_ID: LKD_0x141_IMAGE_atikmpag.sys

BUCKET_ID: LKD_0x141_IMAGE_atikmpag.sys

PRIMARY_PROBLEM_CLASS: LKD_0x141_IMAGE_atikmpag.sys

TARGET_TIME: 2020-03-05T23:48:50.000Z

OSBUILD: 18363

OSSERVICEPACK: 693

SERVICEPACK_NUMBER: 0

OS_REVISION: 0

SUITE_MASK: 784

PRODUCT_TYPE: 1

OSPLATFORM_TYPE: x64

OSNAME: Windows 10

OSEDITION: Windows 10 WinNt TerminalServer SingleUserTS Personal

OS_LOCALE:

USER_LCID: 0

OSBUILD_TIMESTAMP: unknown_date

BUILDDATESTAMP_STR: 160101.0800

BUILDLAB_STR: WinBuild

BUILDOSVER_STR: 10.0.18362.693

ANALYSIS_SESSION_ELAPSED_TIME: c9b

ANALYSIS_SOURCE: KM

FAILURE_ID_HASH_STRING: km:lkd_0x141_image_atikmpag.sys

FAILURE_ID_HASH: {c4561d61-ffbc-583d-5e1a-6fd6e42466ee}

Followup: MachineOwner
---------

 

I'm getting desperate and I have no idea what's going on.

Outcomes