ayyyvega56user

AMD Can i get confirmation on this? Blackscreen 100% / BSOD Thread_Stuck_In_Device_Driver

Discussion created by ayyyvega56user on Feb 22, 2020
Latest reply on Feb 25, 2020 by ayyyvega56user

Hi i think i may have found the issue plaguing many user Myself included with Blackscreen fan 100% / FPS drops in game followed by Blackscreen or BSOD Thread_Stuck_In_Device_Driver...

As to do with either Asmedia USB 3.1 Controller with Asus motherboard when installing Windows 10.Or when Installing windows 10 if Outside of one of the few region which Cortana is disabled (Taiwan for example) all of Cortana feature will be available and the Taskbar will glitch out and be bright white when using Dark Theme.

Step to fix this go into bios do a search (On Asus Prime x470-pro) the shortcut key is F9, in the box type in Asmedia and set it to disabled. Install windows 10 with your internet disabled , when it asks you which region you are in select Taiwan (you can change it later inside of windows in the settings).

 

Now steps to reproduce the blackscreen fan 100% issue and to know if you are affected by it download HWINFO in the settings under Safety tab Uncheck EC Support. launch the sensor. if you crash blackscreen 100% either Asmedia is causing issue or the installation of windows 10 was corrupted by Cortana.

After doing this fix on my clean install of windows 10 using this and the modification done to bios prior of installing windows 10. I was not able to reproduce the Crash using HWINFO. prior to doing this i was able to reproduce it 100% of the time on the DOT.

Systems affected:Asus B85-Plus mobo

i5-4430 processor

Msi RX Vega 56 8gb OC

Windows 10 Home / Pro

all of amd drivers

 

Asus Prime x470-pro

Ryzen 7 2700x

Msi RX Vega 56 8GB OC

windows 10 Home / Pro

all of amd drivers

 

gpu not affected by this on both system

Windows 7 Pro / Windows 10 Home / Windows 10 ProSapphire HD7850 2gb

All of amd drivers

 

TL:DR:

Since april 2019 i have been having constant Bluescreen thread_stuck_in_device_driver (Always saying dxgkrnl.sys or atikmdag.sys being the cause), Or BlackScreen fan 100% at random while gaming or watching youtube videos, Or massive FPS drops that lingers until either a system crash OR pc needs to be restarted. I have changed my PSU which didn't work , i have RMA'd my MSI RX Vega 56 (samsung memory) to a MSI RX Vega 56 (Hynix memory) and i was experiencing the exact same crashes / symptomes.

It may also been caused by Windows not cleaning properly the ssd / hard drive when doing a FORMAT. and somehow old "system recovery" was still lingering and causing issues ???

Steps i did to make sure it was factory clean.. in windows 10 clicking on start -> holding down Shift key -> clicking restart , it brought me in startup option menu. which i then navigated my way to Troubleshooting -> Advanced Option -> Command Prompt

Inside of there i did diskpart -> list disk ( Make sure you are messing around with the right ssd / hard drive to be sure just unplug the sata from your other devices ) -> Select disk # -> Clean -> Create partition -> format disk -> Clean.

Since the issue is so random at times while gaming (i can crash from within 5 mins , to not crash for a day or 2 ) it's hard to be 100% sure it's fixed , but the HWINFO with EC Support disabled method was very reliable. Which makes me believe it's finally fixed???

 

PS: i made the exact same post on r/AMD and within a minute the post got taken down by a moderator.... why?

Outcomes