AnsweredAssumed Answered

AMD Radeon Software Installer Error 182 Issue

Question asked by venoxconquer on Feb 9, 2020

   To start, Minecraft is using my display graphics chip (AMD Radeon(TM) Vega 8 Graphics)  instead of my rendering graphics chip, and I'm guessing that is the specific component that is causing Minecraft to lag spike constantly, despite this being a decent laptop build. I'll get about an average of 14 frames and end up dropping down to 1, making playing the game almost unbearable. 

   To begin trying to fix the issue, I decided to switch having Minecraft use my display GPU to the render one via Radeon settings (Because there's more memory involved in the render graphics card), but for some reason it would refuse to let me completely open it. Stated, "Radeon Settings version and Driver version do not match. Please try again after updating to the latest version(s)." I attempted to fix this via setting the driver versions for all my graphics chips to their latest versions (even the integrated graphics) via device manager but it stated that they already had the latest versions. I even tried going into the registry editor afterwards and setting the driver version to 0 via file location "HKEY_LOCAL_MACHINE\SOFTWARE\AMD\CN".

   Up at this point when I tried opening Radeon settings again, it refused to open at all. It wouldn't even state the error listed before. I tried uninstalling and reinstalling but apparently the "reinstall" part of the process may not even have been possible; though I assumed (and still assume) that it is via the AMD Radeon Software Installer but when I tried installing even that, it came up with error 182. This was when I installed it for support over my render GPU (I have both an APU and 2 different GPUs), so afterwards I tried downloading the same application for my integrated GPU instead. Still the same error comes up every time and It's frustrating considering I just want to switch which GPU Minecraft is using on my laptop.

 

My System info:

Acer (Nitro 5?) Computer

Windows 10 Home 64-bit

Processor: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx (8 CPUs) ~2.0GHz

Memory: 8192MB RAM

Display Graphics: AMD Radeon(TM) Vega 8 Graphics

Render Graphics: Radeon RX 560X Series 

 

Again, if anyone knows how to solve this, please do tell. It would be much appreciated

Outcomes