detrol2k

Sapphire RX 5700 XT Nitro+ Very Odd Issue

Discussion created by detrol2k on Feb 6, 2020
Latest reply on Feb 28, 2020 by detrol2k

So since I bought this card I've been having terrible issues with performance as in the card operating at around 30-40% of it's full potential. 

 

It took ages of asking different people, forums, support tickets until I found the base of the issue. 

 

https://imgur.com/zUNnSyJ

 

As you can clearly see from the BUs Interface the card was locked at PCIE x1 1.1 even if I put it on full load benchmarks, that explained the issue I constantly kept having.

As a first attempt to fix this I went into my BIOS to try and force that PCIE port (marked as number 2) to be on Gen3 from AUTO. Doing so caused black screen during boot and only my integrated graphics worked (plugged the HDMI into my motherboard). 

 

https://imgur.com/rKCBnHu

 

You can clearly see from that image that all the PCIE lanes are set at AUTO

 

https://imgur.com/TCqofyA

 

This was a test, a final solution or the sorts. I basically plugged the card onto my second motherboard PCIE full slot and it worked, only the problem is that it's locked at PCIE x8 3.0 no matter what I try to do. It's as if the card completely hates PCIE x16.

 

I cleaned up the slots, tried every single posibility. I'm at the latest version of BIOS too. Do you guys have any suggestions?

 

Motherboard is ASRock > Fatal1ty Z87 Killer

 

Before this card I've had an RX580 which worked flawlessly, I think I could observe issues if it was locked on PCIE x1 1.1 as this card is on the first slot. 

Outcomes