AnsweredAssumed Answered

2nd Monitor on 3rd Radeon Video Card Blank After Reboot

Question asked by bobpi on Jan 24, 2020

I currently have 3 video cards, RX550XT, RX580, & RX580 with 2 monitors on each card 2 X HDMI, 2 X DP, & 2 X DP. First monitor is a 4k TV running in 1080p for extended color and the rest are 2k monitors.

 

All 6 monitors display after drivers are loaded but the 2nd monitor on the 3rd video card goes blank on a subsequent reboot (not necessarily the first reboot). Windows 7 shows the monitor as an active display and the mouse-pointer disappears when taken to where that monitor should be. The monitor also shows that it has a signal (blue power light) but it is completely black. I am running the latest optional adrenaline drivers but had the same problem with previous drivers and a previous 3 card configuration (RX580,RX580,RX570). It sometimes comes back on its own  and I can get it to come back sometimes with great difficulty replugging the monitor. It even happens if I move the 2nd monitor to the DVI port.

 

I use the first card for my HTPC setup of tv and 2k monitor next to it for the playlist. The second and third card are for a 2X2 2k monitor setup over my computer desk.

 

I originally thought it may have been a limitation with the RX570 card but it is happening still on this new setup. Now it sounds like a Windows or driver bug or PCIe lane problem but I am using a Gigabyte GA-990FXA-UD7 Rev 3.0 with a FX8350 CPU.

 

All video cards are Sapphire Nitro+.

 

Any help would be appreciated.

 

I have found that I can get the monitor back if I hibernate the system.

Outcomes