AnsweredAssumed Answered

Threadripper 3960X Build wont Post, hung at DRAM LED

Question asked by j_ritter on Jan 22, 2020
Latest reply on Jan 23, 2020 by elstaci

Two PC build so all parts were bought at the same time and same specs.

Threadripper 3960X

EVGA 280 CCL cooler

AORUS TRX40 Wifi PRO

128GB HyperX Predtor DDR4 3200

Corsair CM750M power supply

M2. NVME 512GB

TITAN X GPU

 

First PC Build  went flawlessly and booted first try. Installed windows and runs without issue.

 

The second was quite different. no Post on first try, AORUS Board only has 4 LED as debug. LED Hung at DRAM LED. I have taken the following troubleshooting steps

 

1. removed all ram inserted one stick- hung at DRAM LED

2. tried all 8 ram sticks individually and dual - hung at DRAM lED

3. tried (2) different sets of ballistic sport DDR 4 ram- hung at DRAM LED

2. CMOS battery reset - hung at DRAM LED

3. CMOS Jumper Reset - hung at DRAM LED

4. removed CPU checked for bent pins, none noted replaced CPU/Cooler - hung at DRAM LED

5. Removed CPU and placed it into the good working rig. - still hung at DRAM LED

 

At this point I am fairly convinced that the CPU is bad or fried? I tried most standard fixes and even swapped the chip into the other build that I did with the same issue. Any other ideas or troubleshooting I can attempt before returning?

Outcomes