AnsweredAssumed Answered

Sapphire RX480 Nitro+ 8GB stopped working.

Question asked by sebastianflorkow on Jan 5, 2020

Yesterday my PC randomly restarted during some light-weight gaming. Upon restarting no image was being displayed on the screen despite the system booting succesfully. Tried switching from DP to HDMI but that didn't work.Then I plugged DP cable into my motherboard to use the iGPU of my processor and that worked properly, allowing me to find out that UEFI doesn't even pick the card up being inserted in a PCIE slot anymore.
Card's LEDs light up, fans don't spin. Putting it into another PCIE slot does nothing.
Tried a backup card and it worked without any issues, so it's not my motherboard being the problem.
Did the card die on me?
That'd be pretty upsetting considering it's barely 3 years old, has never been overclocked and hasn't seen much dust due to proper cleaning.
Is there anything else that I should do, or am I out of options?
My system:
i5 6600K
2x8GB of 3200MHz ram
Sapphire RX480 Nitro+ 8GB

Outcomes