AnsweredAssumed Answered

Adrenalin 2020 Edition 19.12.2 software install stops

Question asked by asterrameth on Jan 1, 2020

Turned on my computer this morning and recieved an alert that my AMD graphics drivers required updating so using the software I had at the time (dont recall what it was  called) went ahead with updating my drivers and installing the latest Adrenalin 2020 Edition 19.12.2 drivers and attached software. Apparently the drivers have installed butthe software will never complete. I have attempted to install it at least 4 times now and after the drivers install and it refreshes my monitors it changes to "Installing Radeon Software" and after 30 seconds of progress it just stops and never completes. First time i let it sit there for well over 10 minutes. I tried turning my firewall off as well and that failed 2 attempts as well. It will just stop every time the little progress bar keeps changing from light red to dark red but it never progresses. The time remaining is always first to glitch out and quit updating shortly after the rest of t just.. stops. I have tried googling for the past hour for a resolution but no one else on earth seems to have this problem as the only results are not related to my problem (talking about getting error messages or games glitching - I'm getting neither I havent tried a game yet as even paint seems to be lagging now)

 

I am using windows 10 and i have tried it with firewall turn off, as already mentioned. I'm absolutely lost I am not a technical genius when this stuff happens its broken forever untill someone can fix it for me. please help.

 

Oh a quick edit too, my pc still shows i have "AMD Settings" installed but when i try to run it I get "Radeon Settings and Driver versions do not match. Please try again after updating to the latest version(s)."

 

screenshot of Installing Radeon Software stopping and never finishing

Outcomes