AnsweredAssumed Answered

Freesync doesn't work / barerly work

Question asked by xhype on Dec 25, 2019
Latest reply on Dec 26, 2019 by xhype
  • AMD Graphics Card
    • XFX RX 590
  • Desktop or Laptop System
    • Desktop
  • Operating System
    •  Windows 10 64bit
  • Driver version installed
    • Latest radeon relive 2020 
  • Display Devices
    • Acer FULL HD 75hz freesync gaming monitor
  • Motherboard + Bios Revision
    • Asrock
  • CPU/APU
    • R5 2600
  • Power Supply Unit  Make, Model & Wattage
  • I'll say if really needed
  • RAM
    • 16GB DDR4 (x2 8GB)

 

Describe your issue:

  • I think you can see in this video it clearly in TF2 game:

    TF2 Screen tearing With Freesync ON / Freesync+Ehnhanced sync - YouTube 

    Same thing happens in all games.

    How do I get rid of it? I have new monitor, let me give you all needed specs:

    Video card: RX 590 (compatible with Freesync)

    Monitor: Acer 75hz (freesync range 48-75hz)

    Latest AMD drivers (2020 version)

    In video I linked above, I used radeon chill, set to freesync range.

     

    Also, I noticed that in games supporting motion blur, when enabled I really feel smooth game.

    Would like to see it without enabling motion blur.

     

    What have I tried:

    1. Use older drivers (only 2019 versions)

    2. Manage options - turning off/on some stuff etc.

    3. Reinstalling (amd total utility program, program default settings, manually..)

    4. Tried on both HDMI (I have 2 random models)

     

    I would be very appreciate for help, epic gamers.

Visibility:  Knowledge Base98099 Views
Last modified on Jul 4, 2017 11:02 AM
Tags:required information
Content tagged with required information

Outcomes