AnsweredAssumed Answered

Black screen when installing drivers

Question asked by darfanda on Dec 24, 2019
Latest reply on Dec 26, 2019 by goodplay

Hi,

 

I know what you're gonna say, again a black screen drivers case but i'm really desperate. I've read a lot of post there and on reddit and i cannot find any solution.
First i'm new with AMD i decided to change an took a AMD Radeon RX 5700 XT. Right before installing the new card i decided to fully clean my computer and a clean windows 10 install, everything's done. Card is working but when i try to install any drivers my screen turn black around 70-80% of the instal (computer still working) and even if i wait 10 minutes, nothing will change, if i reboot my screen turn black with "no signal" right before the login screen of windows.

 

I've read that this is a problem with windows 10 trying to install the driver at the exact same time, fine so i unpluged internet, clean uninstall of ALL drivers with amdcleanuputility-x64 and even DDU (in safe mode of course), look up of the ID's of the driver i'm trying to install (last one 19.12.2) go on GPEDIT System>Device Installation>Device Installation Restrictions "Prevent Installation of devices that match any of these ID" added the ID's, because i was not sure, i added all the ID of the driver i could find. Still the same problem, i even tried to remove every AMD drivers install from my computer and put the driver on a USB Drive to install it, still same problem.
I'm pretty sure that my card is working, it's brand new and also i don't remember exactly how i did it but with all my trying i once saw windows trying to install the driver himself while i was trying to resolve my problem and black screen again without me trying to install it, so it's seems to be true that windows 10 is the problem. I've also tried a weird solution i did find on this forum "installing the amd driver, wait after the black screen, turn off your PC, remove AMD card, put Nvidia card, install Nvidia driver without removing amd driver, turn off and go back to AMD card" of course that didn't worked.
Note i've also tried to install the driver from windows device manager. And also tried to install some older drivers (not everything) like 19.12.1 and 19.11.3

So for my computer : 
- Windows 10 pro 64 bits (latest patch, from a fresh install so i think) on a SSD
- Motherboard : GIGABYTE AORUS Z270X-Gaming 5
- Proc : Intel Core i7-7700K 4.20GHz LGA1151 - KABYLAKE

- Ram : 4x8go Ballistix DDR4 3000 MT/s (PC4-24000) CL15
- Sapphire Nitro+ Radeon RX 5700 XT 8G GDDR6 Dual HDMI/ Dual DP OC
- Screen : BenQ PD3200U 32" 4K UHD...

I'll put a screen of the ID Drivers i did put in Device installation restrictions, it's in french, sorry, but the id's is the same.

I'm starting to be really desesperate any help would be appreciated, i cannot find any solution on internet, i'm not a noob with computer but i'm not expert neither, and i think this is a shame to put so much effort just for a driver, a lot of people say it this normal with AMD but i'm sorry it is not normal. I would really want a solution for the latest driver but if there is none i would accept older drivers or as a last resort maybe go to windows 7 but that would be a loose to me.

Thanks for you time, with love, Darf.

Attachments

Outcomes