alejandro2004

After AMD Display Drivers Installation the Windows ui(like the start menu and notification center)do not show properly(they are like almost invisible)

Discussion created by alejandro2004 on Dec 14, 2019

Hello!

I have been trying to figure out a fix for the problem described in the title,after the installation of the Amd drivers using the auto-detect,the windows ui literally does not show,when I go into the start menu it shows nothing,but if i go over where usually there would be a tab a glitch like a shadow is showing idk how to say it I want to mention that google chrome does not work either(not showing properly) also if I go into Settings after some seconds my laptop shows  a BSOD with the error message:NMI_HARDWARE_FAILURE

Please I am desperate because it makes my laptop unusable and I really need it for projects and etc.

I tried to search the BSOD error and tried a lot of fixes from a site but nothing worked

Also I must mention that the laptop works fine without the drivers it just is a bit slow and lags

A few days ago it was working very good without the drivers even tough i made an update from windows that said someting like AMD Display(or something like that)

But when I updated my drivers with the driver booster 6 and installed the display drivers it did not work again

At this moment i tried a lot of fixes but they do not work,at the moment my laptop has no display drivers installed and it is very slow and lags,please help!!!!!

Laptop Specifications:

Model:Asus X555DG

Processor:FX-8800P,4C+8G 2.10GHz

RAM:12GB

OS:Windows 10 pro version 1903 build 18362.535

Graphic:AMD RADEON R7 GRAPHICS+RADEON R8 M350DX DUAL GRAPHICS WITH 2GB DDR3 VRAM Built-in FX-8800P

Please I really want to use my laptop with the display drivers installed because without them it is very slow!

Outcomes