AnsweredAssumed Answered

Disable CPU turbo

Question asked by steelwolf19 on Dec 13, 2019
Latest reply on Dec 30, 2019 by steelwolf19

I have spent awhile looking at different forums and places trying to figure this out and yet to learn anything that is helpful. With this newly built computer of mine I have discovered that the CPU is running above the base stock GHZs normally about 4.4 ghz from windows 10 task manager or 3600mz to 4499mhz according to MSI CPU-Z. I am running a AMD Ryzen 7 3800X on a MSI 570x motherboard everything is up to date and I am sure this is the windows 10 cpu turbo causing me problems. 


I wouldn't worry so much if it wasn't for the reving up and down of my cpu fan and the added heat while idling. Is there a way to disable this easily without voiding my warranty? Also I've been having issues getting into windows 10 bios to fix this.