AnsweredAssumed Answered

ryzen 3 2200g no display

Question asked by mrr147 on Dec 7, 2019
Latest reply on Dec 14, 2019 by elstaci

Hi

I've built my pc and it posted to bios, I've set up XMP profile (3200MHz) on my memory, it reset and was working fine.

I shutdown pc, plugged in some sata drives, powered on and went to bios. Screen froze right after bios loaded, I couldn't do anything so hard reset was only option. I tried to get into bios again but this time it froze on splash screen. One more reset and there was no display output anymore. I've tried reseating ram, unplugging sata drives, plugged cpu and mobo power, resetting cmos with and without battery, put in dedicated gpu from my other pc(yes switched hdmi cable to gpu), tried with 2 different monitors, 4 different cables hdmi and dvi, still no display.

At first I've tested everything before putting the system in to the case. After I assembled everything, powered on one more time to check if it's still ok, powered off. Connected two sata drives, powered on and that's where the trouble began. PC still turns on, fans are spinning, mobo leds are lightning up and so are lights on keyboard(although now they all light up, instead of just numlock).

 

What could be at fault here? Please help.

 

My specs

CPU: Ryzen 3 2200g with stock cooler

RAM: Patriot 16GB 3600MHz Viper 4 Blackout CL17 (2x8GB)(PVB416G360C7K)

MOBO: ASUS Prime B450-PLUS

PSU: SilentiumPC Vero L2 500W 80+ Bronze

GPU I tried is MSI GTX970 which works fine on my other PC

Outcomes