AnsweredAssumed Answered

3 monitor setup not working but 2 or less does

Question asked by cryptiiks on Dec 4, 2019

So I installed a new stick of RAM and when i booted up i went to Bios and exited right away. immediately after My 3rd monitor on my pc stopped being detected. When I have two monitors installed to the Radeon RX 580 it detects both but as soon as I install the 3rd monitor, it only detects on of them. it only allows me to stretch my resolution to cover all 3 monitors but shows it as only one detected. as long as two monitors or less are hooked up it works. but as soon as I plug in the third one it pretends theres only one plugged in. I have removed the RAM and reinstalled the previous set and it is doing the same thing. I have reset CMOS. I have tried to manually detect. nothing works but 30 minutes ago every thing was fine. Here are my specs:

OS Name Microsoft Windows 10 Home Version 10.0.17763

Build 17763

Other OS Description Not Available

OS Manufacturer Microsoft Corporation

System Name GLADIATOR

System Manufacturer Micro-Star International Co., Ltd

System Model MS-7C02

System Type x64-based PC System SKU To be filled by O.E.M.

Processor AMD Ryzen 5 2600 Six-Core Processor, 3400 Mhz, 6 Core(s), 12 Logical Processor(s)

BIOS Version/Date American Megatrends Inc. 1.20, 9/21/2018

SMBIOS Version 2.8

Embedded Controller Version 255.255

BIOS Mode Legacy

BaseBoard Manufacturer Micro-Star International Co., Ltd

BaseBoard Product B450 TOMAHAWK (MS-7C02)

BaseBoard Version 1.0

Platform Role Desktop     

GPU Radeon RX 580 Series

Outcomes