kristijan

AMD RX 5700 XT freezing the PC

Discussion created by kristijan on Dec 5, 2019
Latest reply on Dec 10, 2019 by hardcoregames™

Hello all,

 

I've updated my PC a few days ago from a R9 270 to the 5700 XT.

These are my specs:

Mainboard - Gigabyte h81m-s2pv

CPU - Intel i5 - 4460

GPU - XFX RX 5700 XT

RAM - SiliconPower DDR3 2x4GB

PSU - Thermaltake Smart SE 630W

 

I'm having issues since the GPU install. When I play older games (TES Skyrim, AOE II Enchanted) everything runs just fine.

When I start Metro Exodus or The Outer Worlds, the PC just freezes before or on the main menu screen.

I've tried the Furmark GPU test and it freezes the PC immediately on the start of the test (tried multiple resolutions).

When I start Metro Exodus in the safe mode (everything on ultra but the resolution on 1280x720 instead of native 1920x1080), it runs for a 10 or 15 minutes and freezes. If I change the resolution to the native one it freezes after a few seconds.

I've removed drivers with DDU in safe mode multiple times, tried both the optional 19.12.1 and 19.9.2 versions, reinstalled the Windows 10, updated it to the newest build - 1909, always with the same issue. I've tried another PSU (600w) and the PC just reboots instead of freezing. I've tried limiting the FPS with the FRTC (tried 60 and 50 fps) but it only gives me like a second or two more before freezing.

 

Is the problem with the PSU, drivers, card itself?

 

PS: When i put back my old R9 270 everything works perfectly fine.

Outcomes