AnsweredAssumed Answered

AMD Link disconnects Shield TV when ReLive enabled

Question asked by deepseadozzer on Dec 5, 2019
Latest reply on Dec 10, 2019 by tastyratz

I'm having trouble connecting an Nvidia Shield Pro (2019) to my PC using AMD Link.  I can connect to the PC, but it immediately disconnects.

 

SOFTWARE

AMD Link software version  2.5.190920 (Sep 20)

I've also updated radeon software to version 19.12.1 (Adrenalin)

Windows 10 (64 bit)

Windows Defender / Firewall are only Anti-virus software products installed.  I've setup the "Auto-configure Windows Firewall" settings, I've also manually added the "radeonsettings.exe" file as an exception in Windows Defender.  I've even tried disabling firewall altogether, results are the same.

 

HARDWARE

PC: Intel i7-9700K @3.60 Ghz

16GB Ram

Radeon RX 590 graphics card

Using Ethernet connection to switch, then router

 

CLIENT

Nvidia Shield TV Pro (2019) which has just been installed / updated to latest software.

Using Ethernet connection to switch, then router

 

ROUTER

Asus RT-AC86u

 

AMD Link settings:

I've tried both manual AND "Auto Connect Discovery", my "Shield Android TV" is listed as a device in the AMD Link Configuration page.

 

ISSUE:

The issue is a strange one.  I can launch the AMD Link client on my Shield TV, it automatically detects my PC on the same Ethernet network.  If I click to connect, it connects successfully and displays the "Connected to XXXX" message.  I then get two icons (as expected) - Gaming / Media.

 

If I click on Gaming, I see "Remote Play is Disabled", "Enable remote play in ReLive on your PC to access this functionality"

If I click on Media, I see "ReLive is Disabled", "Enable ReLive on your PC to access this functionality"

 

As soon as I go into Radeon Settings and switch ReLive toggle to "On", my Shield TV immediately disconnects.  If I turn on these settings before attempting to connect to the PC any attempt to connect fails, sort of...I get a "Connected" notification on my PC and Shield TV, but that is immediately followed by a "Disconnected" message.

 

Global settings in ReLive:

Relive: On

Record Desktop: Disabled (although I've tried with Enabled to)

Save Folder is set

Borderless Region Capture: Disabled

Everything else is at default settings, I haven't changed anything

 

Game & VR Streaming tab in ReLive:

Remote Play: Enabled

Steam VR not installed

 

I'd be tearing my hair out if I had any....I cannot understand why I'm able to connect using AMD Link, but as soon as any of the features are enabled (ReLive), I am automatically disconnected. 

 

Any ideas where I can go to find out what is happening here or anywhere I can gather logs? 

Thanks!

Outcomes