drazen

RAID drivers update makes second NVMe invisible

Discussion created by drazen on Dec 2, 2019
Latest reply on Dec 11, 2019 by drazen

My PC is Gigabyte x570 Ultra with 3900x, two NVMe drives NOT in RAID and two SATA in RAID. Latest BIOS (F10). Win10 1903.

Everything worked ok with RAID drivers 9.2.0.105. Both NVMes archived 3400 - 3500 Mbs read speed. SATA RAID is very slow but that's other problem.

Cause of plans to upgrade Win 10 to 1909 I updated my chipset and RAID drivers to latest one (1.11.22.0454 & 9.3.0.38). After upgrade (and reboot) my second NVMe is invisible! SATA RAID is ok and my boot NVMe (first one) is also ok.

On second NVMe I have same Win 10 but without latest drivers and it works ok (copy of original Win 10 for cases like this).

I tried following:

  1. System Restore - does not work (probably cause of missing drive)
  2. Uninstalling everything from AMD (Control Panel and Apps & features) - does not work
  3. Manually uninstalling RAID drivers as in rft document - no help
  4. Disabling RAID in BIOS - no help

 

Only what helps is to:

  1. Enable NVMe RAID in BIOS

 

After enabling NVMe RAID I finally see my second NVMe (and of course SATA RAID). But, second NVMe speed dropped 50% !!!!!  I'm using Samsung Magician (first NVMe is 970 Pro 1TB) for measurements and speed of first NVMe (in this case boot drive) did not changed (3700 read, 3400 write) but second NVMe (AData 8200 Pro 2TB) is now half the prev speed - 1400 read!

When I run RAIDXpert my second NVMe is listed as Legacy. That's ok cause RAID must be enabled on NVMe to see this drive.

BTW RAID version 9.2 uses web based interface while 9.3 is UWP app.

 

Above I mentioned my catastrophic SATA speed. I have two 12TB IronWolf drives in mirror. Write speed is some 10 MB/s!? For smaller files is even worse! Unfortunately I don't have third drive to test without SATA RAID but if my NVMe dropped 50%...

 

 

Could someone help how to get rid of NVMe RAID driver?

How to forcibly remove it from system and prevent future problems (besides AMD to fix their sw problems).

 

Outcomes