AnsweredAssumed Answered

ProRender plugin crashes Blender immediately all of a sudden.

Question asked by jl5086 on Nov 30, 2019
Latest reply on Dec 8, 2019 by jl5086

On my second PC,(an iMac with Windows) Blender and ProRender has always worked great, I have had Blender 2.80 and 2.81 installed on it, and have been using RPR 2.0.162 just fine.  It worked yesterday morning, then in the evening I tried to open Blender and it crashes at the gray screen, and it does this for either version of blender.  The only way Blender will run is if I manually remove the rprblender folder from the addons folder.  I tried reinstalling Blender and ProRender, with the same results, although after completely reinstalling ProRender, then, Blender doesn't crash until I tick the box to enable RPR, then it crashes right to the desktop.   I did run Blender through the command prompt, and I have included a screenshot of the command line errors it produces.   Also, it's probably not related, but I still, on both my computers, get the same error during install of prorender, saying "it cant find python.exe in a specific location, did I type it right?"  but the python.exe file is in that location, although the path written in the error message is sorta different (see the screen shot below).  This error during RPR install is not new, and has been doing that for months, so I doubt it has anything to do with why ProRender all of a sudden just stopped working on this machine yesterday.  I did also run "dism/restore health..." command to fix any OS errors yesterday after all this happened.  Because this computer is running bootcamp I cant update to the latest AMD display drivers, I have to use the bootcamp drivers that are available, so they are 18.2.2, but like I said before, RPR has always worked fine, and even yesterday morning RPR was working fine, so I'm a bit stumped here, both my PCs are up to date with all windows updates, although this PC(iMac) is on version 1809, and my gaming PC is on 1909, but I don't want to upgrade this one yet because not surprisingly after doing the 1909 update to my gaming PC, a few of my games just stopped loading, and Windows will not let me go back to v1809 on that PC now, so I am forced to play those games on my crappy Mac, instead of my purpose built gaming rig,  go figure.  But I do like using Blender with ProRender on this iMac because it looks great on the 5k screen, i have 40gb of ram, and the Pro 570 4gb GPU manages to do a decent enough job at it.   I really hope to get this problem resolved so I can use it again, in the meantime I will try to locate an older version of RPR and see if that may work again, thanks.

 

This is the command prompt message when ProRender causes Blender to crash at loading.

 

I've been getting this error when installing RPR for months.

Outcomes