AnsweredAssumed Answered

Video - only green picture visible

Question asked by hanhub on Nov 27, 2019
Latest reply on Nov 28, 2019 by kingfish

Hi everybody!

 

My system:
- Sapphire Vapor-X HD 4870 1GB GDDR5 PCI-E graphics card
- Windows 10 64 bit with latest updates
- 16 GB RAM
- Monitor 24 Inch Dell UlatraSharp U2410; working at 1920 x 1200 resolution

 

When I play videos, I hear the sound, but instead of the video I only see a green picture.

It doesn't matter if I use the VLC Player or the Windows Media Player.

Only videos with a picture width of 640 or 480 work. Also playing Youtube videos in HD works, even in full screen mode.

There are no indications of problems in the Windows 10 device manager.

With Windows 7 on the same computer (I have installed a backup for test purposes) I can play all video formats without any problems and independent of the software I use

So far I have found the following to solve the problem:
- Install the latest graphics driver or let Windows search for the latest driver (but according to Windows I have the latest one).
- Uninstalling / reinstalling VLC or deleting the VLC cache. I didn't do that, because the problem also exists with Windows Media Player.
- Reduce monitor resolution of (normaly) 1920 x 1200

 

So far I haven't found a solution.

 

Concerning the graphics driver:

I installed the driver/software package for Windows 8 64bit from this AMD site.

There is no special Windows 10 driver, but often Windows 8 drivers also work with Windows 10, which I wanted to try out.

I also assume that I would have received a hint during the installation if the driver was not suitable or that I would not have been able to install it in the first place. And Windows 10 reports with the (repeated) driver update that the best driver is installed with it.

And it all works, but only with the exception of videos larger than 640 picture width. I can also set other screen resolutions, for example.

There is only one thing I noticed:

When trying to start the Catalyst Control Center, an error message appears (I am German, so I try to tranlate the message):

"Catalyst Control Center cannot be started. There are currently no more settings available that can be configured with Catalyst Control Center".

Due to the device manager this driver is installed:

 Advanced Micro Devices

dated 13.01.2015 (my graphics card is from 2009).

driver version 8.970.100.9001

 

Can anyone help me?

Outcomes