AnsweredAssumed Answered

RX 5700 "no signal" when i download the drivers

Question asked by tonali on Nov 17, 2019

Hi 

(sorry for the poor english, it is not my native language) 

I had a vega 56 one month ago but it died, so, i replaced it by a RX 5700 yesterday ,i currently use a Nvidia gt 730 to use my computer.

So the first time i put my rx 5700 in i used HDMI, my computer starts, i see the bios: no problem, i see the windows icon: no problem, then when it load my desktop after 2 second on desktop "no signal", i tried to restart many time but every time it's the same problem. 

In that state i can run windows through safe mode, i used amd cleanup utility and ddu to uninstall all the drivers, then when i tried to install the drivers for rx 5700 i had 2 error:

 

https://www.amd.com/fr/support/kb/faq/gpu-kb1603  this error never came back

https://www.amd.com/fr/support/kb/faq/gpu-kb99 I disabled the control for "digital signature" and never see it again too

 

 

So i could install the drivers for rx5700 but when the drivers are installed, "no signal" issues came back. 

 

I tried to:
-Clear Cmos
-Reset Ram
-Update Bios

-Disable FreSync
-Tried many version of drivers for this card
-Used another windows version and another SSD (same problem) 
-Tried the 2 PCIe x16 3.0 i have 
-Test my PSU 8pins (everything is fine ~12v per pins)
-I tried the BIOS "Boost" and "Silent" on the card 
-I tried to use other GPU (and they works, i'm curently using a little gpu Nvidia GT730) to run my pc) 

 

Facts:
-I cannot try DP

-My GPU is listed in my device list (in windows safe mode) 

-Fan don't run and my Gpu heats 

-Power suply Led on GPU Are both "ok" (blue) 

 

My specs:

 

Motherboard: ASRock X370 Pro4
Bios Version: P5.80 24/06/2019

 

CPU: Ryzen 7 1700
GPU: XFX RX5700
RAM: G.Skill 16 Go DDR4-3000
SSD: Crucial® BX500 240GB 3D NAND
HDD: WD Blue, Disque dur 1 To

PSU: Enermax Revolution DUO 600W Gold 80 plus

 

Os:Windows 10 Pro OEM
Version: 1903
Os Version: 18362.476

 

Screen: Acer 23.8" LED - EB243YAbix

 

I tried everything i could i seriously need help. 

Thx u for people who read this to try to help me. 

Outcomes