AnsweredAssumed Answered

Problem with MSI HD7770 1GB HDMI and DVI ports stopped working...

Question asked by mixxlegend on Nov 15, 2019

Hi all good people, i register to AMD in hope someone can help me...
i have this card MSI HD7770 1gb "R7770-PMD1GD5" for years and problem started when i connected broken defective-damaged HDMI cable... Before this my graphic card worked perfect on all outputs (i have 3 monitors) first monitor (my primary) connected from graphic card DISPLAYPORT to VGA active converter, second monitor HDMI to VGA active converter and third monitor DVI to DVI... This monitors setup worked for years (eyefinity) and one day i decide to test some hdmi cable i found to see if its working... i plugged in maybe for 20 seconds from my pc (HDMI to HDMI) to my projector, picture was defetive and snowy and i plugged it out and THAT'S when i connected back my monitors and later tryed to extend my displays i found out that my two monitors connected on HDMI and DVI on graphic card are no longer recognized and only working monitor left is this i'm using DISPLAYPORT to VGA...
I tryed EVERYTHING! from changing 5 different cables all type, cable adapters, monitors, rolling older gpu drivers(DDU), reflashing VBIOS 2 times... NOTHING HDMI and DVI outputs on graphic card are simply dead...most recent i found out if i connect on this "working" DISPLAYPORT on card... DISPLAYPORT to HDMI adapter there is also no picture... but DISPLAYPORT to VGA works normaly, and i found out DVI to VGA giving poor quality picture but that is analog...
In one word i think graphic card stopped giving digital signal on all outputs, only analog left and i'm 99% sure its gpu hardware fault some kind of short happen with defective hdmi cable... Can anybody help me how i can solve this problem?
Is there any way to force amd drivers digital output in registry?
i really love this grapghic card and i will do whatever it takes to fix it... please help

Outcomes