AnsweredAssumed Answered

Powercolor RX 5700xt red vga led on after working fine.

Question asked by bogdan.berbece90 on Nov 12, 2019

Although not great to see all these comments, I'm happy I'm not alone here. I bought my powercolor 5700xt in sept, and occasionally I'd have my monitor turn black with No DP signal message coming up, a restart would fix it, but yesterday the screen went black and now the red VGA led on motherboard is red regardless of OC/Silent mode I have just installed a day prior to this the latest "Optional" update from AMD. No idea if this is the issue or not, but i've tried installing that driver 4-5 times and it BSOD every time.

 

My config is 2700x, 16gb ram 3333 hyperx, corsair hx850 PSU, and msi 450 carbon. I have requested an RMA number to have it shipped back but i'm afraid they will tell me the card is fine physically. I have no way to reinstall windows and start fresh or delete the drivers as my cpu does not have video output to get into bios/windows.

 

Took my pc to a repair shop and they tried 4 cards in my pc and they worked fine, but they couldn't test the card in other pc's as they did not have a 8x2 pin connector. What would be my options here if the RMA comes back clean? Buy a very cheap video card, delete all the drivers and try again? If that's the option, would any cheap video card work? Found some on ebay for 10 bucks. Would very much apreciate any input

 

Note: Tried all possible PSU cable permutations, but the issue persisted. All the other components, LED lights, strips, rgb stuff powers on normally

Outcomes