zxteo

Sapphire Nitro+ rx 580 uncontrollable fan speed

Discussion created by zxteo on Nov 11, 2019
Latest reply on Nov 13, 2019 by zxteo

TL:DR  It has 2 fans. 1 of its fan speed can be adjusted while the other just maintains about 60%+ -ish fan speed since startup even at idle. I tried MSI afterburner, Sapphire TRIXX and amd wattman all yield the same result.

 

   So here's the problem, I bought a second hand sapphire nitro+ rx 580 8gb a while ago from someone whom I suspected to be a miner but the price is too good of a deal to refuse. Everything is working fine just that one of the fan just seemed to stay in its own "auto mode" with a really steep fan curve while the other fan is under my control. Even while idling between 40-45c, the said fan seems to be spinning at around 60% or higher based on the sound. Performance wise nothing was affected however the loud fan is killing me.

 

   I tried using MSI afterburner, Sapphire TRIXX and amd wattman all yield the same result. They all show that the fan is at 0 rpm while idle yet the said fan is still spinning loud. Although if left idle long enough the fan drops down to around 20% judging by the sound for a short while before it ramps up again.

 

   Does anyone know whether if this is a software/hardware failure, bios issue, corrupted driver or something else? And if there are any solutions to it.

 

Note: The faulty fan is the one furthest away from the mounting bracket.

 

My specs:

Mobo: Asrock AB350m-hdv

CPU: Ryzen 5 2600

GPU: Nitro+ rx 580 8gb

RAM: 2 x 8gb Corsair Vengence 2933mhz

PSU: Cooler Master MWE gold 550w

Outcomes