AnsweredAssumed Answered

5700 driver not used in Ubuntu 18.04.3

Question asked by poggs on Nov 10, 2019
Latest reply on Nov 10, 2019 by billy72

I've just bought an AMD-brand Radeon 5700 (RX5700-8G | Graphics Cards | ASUS Global) and fitted it to my Asus PRIME-X299-A in place of a Radeon WX4100.  I have three 4K monitors connected over DisplayPort cables.

 

Running kernel 4.18.0-25-generic and having installed the 19.30-934563 drivers, the amdgpu kernel module isn't loaded and X starts with a framebuffer at 1024x768 on one of my three screens.  modprobe-ing the module results in:

 

[ 28.967507] amdgpu: Unknown symbol amd_iommu_bind_pasid (err 0)
[ 28.967743] amdgpu: Unknown symbol amd_iommu_set_invalidate_ctx_cb (err 0)
[ 28.967870] amdgpu: Unknown symbol amd_iommu_free_device (err 0)
[ 28.968458] amdgpu: Unknown symbol amd_iommu_unbind_pasid (err 0)
[ 28.968510] amdgpu: Unknown symbol amd_iommu_init_device (err 0)
[ 28.968750] amdgpu: Unknown symbol amd_iommu_set_invalid_ppr_cb (err 0)

 

On a 4.15 kernel, amdgpu loads but X won't start - see the attached Xorg.0.log - same for a 5.0 kernel, and I see segfaults in libdrm_amdgpu.so.1.0.0 in dmesg:

 

[ 19.692755] gnome-session-c[4095]: segfault at 10 ip 00007f7f8d5e6530 sp 00007fffefbe2260 error 4 in libdrm_amdgpu.so.1.0.0[7f7f8d5de000+c000]
[ 19.692759] Code: ba 20 00 00 00 be 00 00 00 00 48 89 c7 e8 58 a5 ff ff 48 8b 45 b8 48 89 45 d0 8b 45 c0 89 45 d8 8b 45 c4 89 45 dc 48 8b 45 c8 <8b> 40 10 48 8d 55 d0 b9 20 00 00 00 be 05 00 00 00 89 c7 e8 48 a7
[ 20.735705] gnome-session-c[4166]: segfault at 10 ip 00007fb8443e6530 sp 00007ffd1f3ee2d0 error 4 in libdrm_amdgpu.so.1.0.0[7fb8443de000+c000]
[ 20.735709] Code: ba 20 00 00 00 be 00 00 00 00 48 89 c7 e8 58 a5 ff ff 48 8b 45 b8 48 89 45 d0 8b 45 c0 89 45 d8 8b 45 c4 89 45 dc 48 8b 45 c8 <8b> 40 10 48 8d 55 d0 b9 20 00 00 00 be 05 00 00 00 89 c7 e8 48 a7
[ 21.811015] gnome-session-c[4236]: segfault at 10 ip 00007f1fe37e6530 sp 00007fff1ae2a1e0 error 4 in libdrm_amdgpu.so.1.0.0[7f1fe37de000+c000]
[ 21.811020] Code: ba 20 00 00 00 be 00 00 00 00 48 89 c7 e8 58 a5 ff ff 48 8b 45 b8 48 89 45 d0 8b 45 c0 89 45 d8 8b 45 c4 89 45 dc 48 8b 45 c8 <8b> 40 10 48 8d 55 d0 b9 20 00 00 00 be 05 00 00 00 89 c7 e8 48 a7
[ 22.927911] gnome-session-c[4600]: segfault at 10 ip 00007f629dbe6530 sp 00007ffc8fef9e50 error 4 in libdrm_amdgpu.so.1.0.0[7f629dbde000+c000]
[ 22.927915] Code: ba 20 00 00 00 be 00 00 00 00 48 89 c7 e8 58 a5 ff ff 48 8b 45 b8 48 89 45 d0 8b 45 c0 89 45 d8 8b 45 c4 89 45 dc 48 8b 45 c8 <8b> 40 10 48 8d 55 d0 b9 20 00 00 00 be 05 00 00 00 89 c7 e8 48 a7
[ 24.048019] gnome-session-c[4739]: segfault at 10 ip 00007f091cfe6530 sp 00007ffc67f77130 error 4 in libdrm_amdgpu.so.1.0.0[7f091cfde000+c000]
[ 24.048023] Code: ba 20 00 00 00 be 00 00 00 00 48 89 c7 e8 58 a5 ff ff 48 8b 45 b8 48 89 45 d0 8b 45 c0 89 45 d8 8b 45 c4 89 45 dc 48 8b 45 c8 <8b> 40 10 48 8d 55 d0 b9 20 00 00 00 be 05 00 00 00 89 c7 e8 48 a7

 

Can anyone help?

Attachments

Outcomes