AnsweredAssumed Answered

Performance issues in fullscreen mode (in Chrome and Firefox)

Question asked by cobalt5 on Nov 10, 2019
Latest reply on Nov 28, 2019 by paulpjred

INPORTANT NOTE to moderators, administrators and employees of AMD: this problem occurs not only with my computer, but also occurs on other computers with an AMD graphics card! Therefore, please do not close this topic without carefully reading everything that I write. Thanks for your attention.

 

I use Intel NUC Hades Canyon (NUC8i7HVK). It seems that the problem appears only in fullscreen mode in web browsers (maybe in some other software too, I dont' know). In addition, another person confirmed the presence of this problem on the AMD forum. The user name is mstfbsrn980. I don’t know why, but he subsequently deleted his video, which he posted on YouTube. I saw his video and his problem is exactly the same as mine. The important thing is that our computers are completely different! I have an Intel NUC Hades Canyon (HVK) with an Intel Core i7-8809G processor and an AMD Radeon RX Vega M GH graphics card. He has an Intel Core i5-8600K processor and an AMD Radeon RX 480 graphics card.

 

At the Intel forum, I have already created a similar topic with a description of this problem: https://forums.intel.com/s/question/0D50P00004QVWMySAP/performance-issues-in-fullscreen-mode-in-chrome-and-firefox  But they can't fix it. Intel is only slightly modifying the drivers originally written by AMD. Here is an answer from one of Intel representatives:

"I personally tested this issue with several computers including the Intel NUC8i7HVK, when using D3D11 the issue happens, as mentioned, this was not only observed on the Intel NUC but other computers as well which leads me to believe the issue is not hardware related."

 

Performance issues in Chrome:

  1. Open any YouTube video.
  2. Go to fullscreen mode by pressing the F key.
  3. Open the context menu inside the video with the right mouse button. Move the mouse cursor over the context menu items.

 

The video does not play smoothly (a lot of dropped frames)  This problem does not appear immediately, but after about 4-5 seconds  The faster you move the mouse cursor over the context menu, the more the video slows down and goes jerky. Here is a good example: https://mega.nz/#!TEs0zAYL!fR71p6JDfLaQbW4QOJI-Sy0yX1wQKbTjZJrMzY4JPVA

 

The old version of graphics driver (24.20.11026.2001) also has this problem  To notice it, you need to open on YouTube a video with 60 frames per second. For example:

https://youtu.be/C3M78DFjIC8

https://youtu.be/RkGafC02Szk

 

The problem is almost imperceptible on video with 24/30 frames per second.

 

What is even more absurd is that after launching "Action!" (program from the Polish company "Mirillis") this problem disappears  What the hell is going on?!  You can also get rid of this problem if you open the chrome://flags/ page and choose "D3D9" or "OpenGL" instead of "D3D11" for the "Choose ANGLE graphics backend" option  The problem also disappears if I turn off hardware acceleration in the browser settings. At first I thought the problem was in Chrome. But many others do not have this problem in Chrome!

In the latest version of AMD drivers (18.12.2), this problem is already observed on any video, and not just those that have 24/30 frames per second.

I also tried installing the latest drivers from the official AMD website. But the result is the same. My graphics card is recognized as a Radeon RX Vega 64https://www.amd.com/ru/support/graphics/radeon-rx-vega-series/radeon-rx-vega-series/radeon-rx-vega-64

 

I already created a bug report in the Chromium bug tracker: https://bugs.chromium.org/p/chromium/issues/detail?id=995396

By the way, in version 80.0.3955.4, the Google team disabled "Direct Composition", so the bug does not appear in this version. To enable "Direct Composition" again, you need to specify the following command in the properties of the shortcut at the end of the "Object" field:

--disable_direct_composition=0

 

Performance issues in Firefox:

  1. Open any YouTube video.
  2. Press the F key many times to enter fullscreen mode.

 

The video begins to go jerky and a lot of dropped frames: https://mega.nz/#!yUEkiSZR!cL4dAzI5cJs3LY5IYz9Fp9_4FF_g4Kt1b-ALI0TuXps The video should play smoothly and without jerking. This can be achieved by running the "Action!" program in the background.

 

Link to the video for the test: https://youtu.be/RkGafC02Szk

 

I also created a bug report in Bugzilla: https://bugzilla.mozilla.org/show_bug.cgi?id=1591218

 

Another performance issues in Firefox:

  1. Open Firefox and load this page (for example): https://nightmarish-dream.ru/forum/topic/771-devushki/page/215/
  2. Go to fullscreen mode by pressing the F11 key.
  3. After that, try to drag and drop any image. When you start dragging, you will notice obvious slowdowns, which are not present in windowed mode.

 

As in the first case, after starting the "Action!" program in the background, the problem magically disappears. If you try to record video from the Desktop using the Bandicam app or the Radeon ReLive function built into AMD drivers, the problem disappears and it is impossible to reproduce it. That's why I had to record video on a smartphone  It is also necessary to disable all programs designed to record video from the screen that are running in the background (for example: Action!, OBS etc).

 

You can also check for this problem if you open any video on YouTube in fullscreen mode and start pressing the Win key many times to open the Start menu. The video will go jerky and there will be a lot of dropped frames. This applies to both Chrome and Firefox.

 

From all this, I can conclude that the AMD graphics card is to blame. To be precise, AMD buggy drivers are to blame for everything.

Outcomes