AnsweredAssumed Answered

Driver Detection Issues with Radeon RX 540

Question asked by windfortress on Nov 6, 2019
Latest reply on Nov 9, 2019 by windfortress

Hello everyone,

 

I've had this issue with my AMD drivers for the last around 6 months now. I think this issue started up with one of the Windows 10 updates, it might have been the Anniversary update? I've had this laptop for a little under a year I would say so kind of disappointed that it's already giving me hardware/software problems...

 

Some specs:

  • Acer Aspire 5 A515-41G-12AX
  • Windows 10 Ver. 1809
  • AMD A12-9720P
  • AMD Radeon RX 540 w/ 2GB VRAM
  • 8GB DDR4 Memory
  • 1TB HDD

 

The problem:

After receiving the "Problematic" update, every time I turn on my laptop and load the desktop, I get a window saying that no AMD graphics drivers have been detected or that they are corrupted, and to install the latest drivers from the AMD website. I have tried uninstalling all AMD drivers, going to the Auto-Detection Tool, reinstalling the latest version of Adrenaline drivers, and everything seems to be okay.

 

What happens after reinstalling the AMD drivers is that I can no longer adjust the brightness on my laptop. The slider will go up/down on the screen and in the settings windows but the physical brightness of the laptop "monitor" does not change. I've found that it will be stuck at whatever the last setting was and I adjust my screen brightness on a regular basis so usually 3-4 hours later I'll find that it's too bright for me.

 

So then I go into device manager and update both AMD entries under "Display Adapters". After this, the problem is fixed until I turn my laptop back on again the next day/later in the afternoon. It will kick out the AMD drivers again and I'll start back at square one. This is incredibly annoying because I don't have time to spend 30-45min daily reinstalling and fixing my drivers.

 

I recently tried running the SFC and DISM commands in PowerShell. SFC did not bring up any corrupted results, and when I try to run DISM, the command will register but it will not start a scan. Like there won't be any percentage bars or anything, just the product and version history will come up and the cursor will sit there blinking at me.

 

At this time, I haven't reinstalled any of the AMD drivers yet, so if there's specific ones that I should be installing to increase my chance of success I'd sincerely appreciate it if you let me know which ones they are so I can prioritize.

 

I'm going to try my luck with all of you lovely people before I take it in to someone because I'm a university student and very low on cash. I'm not useless when it comes to computers (and I can do virtually anything with clear instructions), so feel free to suggest things and I can report back with logs or what have you. However, I draw the line at registry edits so if that's the only solution then I'd rather take it to a professional. Thank you in advance! Apologies for the essay-like post lol

Outcomes