jsebela

Cannot install radeon W10 x64 package on W10 1903

Discussion created by jsebela on Nov 1, 2019
Latest reply on Nov 7, 2019 by jsebela

I have installed W10 on my new PC (Ryzen 7 3700X, 16GB (2x8 3600), MSI X570 Gaming Edge Wifi, Corsair MP510 M2 960GB SSD, RX 5700XT Anniv.) on 24/9/2019. Till I tried to install newest drivers release for Outer Worlds, everything worked just fine. Last week I have installed latest driver and during installer's driver detection got freeze/crash and reset. Then adapter stopped working. Nothing worked - not uninstall, not amdcleanup utils and september 2019 WHQL driver nothing. I have just could not install graphics driver.

Then I got angry, backed up important files, formated windows partition from Hiren boot CD, installed brand new W10 1903, and got exactly same problem: the moment the driver installer started detecting drivers it just froze and a little later restarted whole PC.

I have thought: maybe the graphic card went 6 feet under. Then I switched new card (RX5700XT) for older (HD7950) and voilá - windows detected it itself and installed its own driver. Also RX5700XT worked on my old PC (i7-860, 16GB, SATA SSD, W10 x64 1503) just fine, even installer on newest Outer Worlds October 2019 drivers worked fine.

I have returned RX5700XT to new pc and played outer worlds whole week just fine (except I opened inventory when visiting mad scientist on his asteroid, then the game immediately crashed).

 

Today I have again backed-up files, deleted whole partition, made new installed usb drive with W10 1903 x64, installed it on my M2 MP510 SDD, installed chipset drivers package just fine, installed outer worlds driver and... got the same results as above.

 

So can someone please help me?!

Outcomes