raydendarkus

My AMD Radeon R5 M330 is giving my laptop BSOD called " Thread Stuck in Device Driver " so I keep it disabled . Need some advice on repairing it . Tried some fixes but didn't work .

Discussion created by raydendarkus on Oct 27, 2019

Model : Lenovo IdeaPad 300 15-ISIK

Graphics drivers : AMD Radeon R5 M330, Intel HD graphics 520 .

Edit : BlueScreenView detected errors in atikmdag.sys & dxgkrnl.sys .

I am convinced that my AMD driver is causing the issue because if I disable it ,my laptop works fine . I kept it disabled for now .

At first I did a system restore to a previous point . Then startup repair and even reinstalled windows like 3 times . Updated and Rolled back windows ( tried both ) but to my disappointment ,it did not work .

I tried out numerous fixes including updating the driver and rolling back to a previous version but it still doesn't work .

I tried the sfc / scannow and the restore health commands on cmd in safe mode as well .

When I checked on the manufacturer's website, the latest bios version recommended for my laptop was same one as I had so no bios problem .

After that , I reinstalled ,updated and even rolled back my AMD driver . It doesn't work and my laptop gives a BSOD Everytime . Without a dedicated graphics driver , the laptop working is kinda limited . It's been 3.5 years since I used my laptop . Should I grind it out for 1.5 years more and then buy a new one ?

Edit : Before the BSOD happens , I get this notification " Application dxgiadapterac has been blocked from accessing graphics hardware "

Outcomes