AnsweredAssumed Answered

Vega 64 Black Screen at Full Screen

Question asked by blackdrako3000 on Sep 28, 2019

This issue has persisted through driver updates, driver clean installs, windows clean installs, new mobo, new GPU, new RAM, new CPU, SSD clean wipes, cold boots, warm boots, hot boots, etc. I use ASUS Aura to change light color so I can see when my temps are getting too high. Through all of this, the temps never get high. I am basing this off the default, built-in, settings for the program. It's a green, yellow, red scale with no hues in between.

 

Rig:

  • GPU - ASUS ROG Strix Radeon Vega 64
  • Mobo - ASUS ROG Zenith Extreme
  • PSU - EVGA 1600W 80+ Platinum T2
  • RAM - G.Skill 128GB DDR4 3000MHz Quad Channel
  • CPU - AMD Ryzen Threadripper 2990WX
  • SDD - Samsung 970 Evo 2TB M.2
  • Monitor - ASUS 3440x1440 32" UHD 100MHz (AMD version)
  • CPU, Mobo, RAM, and GPU are watercooled

 

The issue was worse at the beginning. Randomly the system would crash no matter what I was doing. I would have to force shutdown before I could use it again. When it would crash, it would give me a greenish screen and the system would crash. When I boot it back up, it would say that Wattman had crashed and been reset to default settings. Besides that message and Windows saying it was shut down improperly, it would boot as if nothing happened. I had never went to the Wattman settings page as I didn't want to use it. Therefore, everything was at default settings and I never agreed to the T&C for Wattman. So how something I never agreed to use and was optional kept crashing my system, I don't know. I fixed this issue by not installing the Radeon Settings part of the driver. Now I just have the following issue.

 

The issue is that I keep getting black screens randomly while doing something full screen. Sometimes I can go 30+ minutes without it. Other times it happens just a few minutes from each other. I could be watching a movie, playing a lightweight hidden object game, playing World of Warcraft, you get the idea. When I first go full screen, the screen flashes between the program and a static screen for a few seconds. After that, it will randomly flash a black screen for a few seconds, then go back to the program as if nothing happened. The system doesn't crash, the programs don't lock up. You can still hear it in the speakers. If you are in the middle of a fire fight on a FPS, you can't afford to have the screen go dark for a few seconds. If I am in windowed mode for whatever I am doing, nothing happens, the system runs as it should. This only happens on full screen mode.

 

Does anyone have any ideas what I could do to fix this?

Outcomes