smilbase

Ryzen 5 3600 always in turbo and throttles instandly

Discussion created by smilbase on Sep 23, 2019

-Windows 10 Pro

-Masterliquid ml 120L RGB

-MSI B450 A-Pro

 

So i just read throw a dozen aritcles from PC Hardwear sites to reddit and i still couldn´t figure out how to solve the problem that im having.

 

So when i first got my 3600 a few days after release i just throught it in there and it was fine (besides the high voltages). After some time i wanted to use the turbo mode but quickly realized that it was unstable in cinebench and csgo with multicore usage enabled (without it was fine but there was no real differents between playing in turbo without multi-usage and playing with stock speed and multi-usage enabled) so i quickly went back to stock speed. Recently i so different articles and statements from AMD that stated that these issues were solved with chipset and biosupdates.

So I got my new aio-cooler today and thought that would be the perfect timing to try the OC mode again.

 

 

After enabling it i saw some wierd things in terms of my cpu speed which started throttleing at 40C° and when i hit 50C° i was at 4 GHz and when running cinebench (stable this time) it went down to 3.6(it went "only" down to 3.8 GHz at most in any game i tested). I saw similar curves in-game as well like csgo ,modern warfare beta and They Are Billions. Then i thought why should i activate the turbo if its only really working when im doing nothing more demanding than browsing with chrome. So i deactivated the turbo again or better i tried even though it is disabled in the bios (btw all changes until now were made in the bios) task manager still shows my cpu at 4.2 GHz in Windows with the same throttle as before. 

 

My problem right now is that i tried everything i read from changing settings in the windows power mode over looking through the bios settings till the offiacl reddit post from AMD (The final word on idle voltages for 3rd Gen ryzen : Amd ) but nothing helps.

 

Something i should clearfy my system is stable but the thing that annoys me is that im wasting electricity for the privilege to listen to my cooler or have a system with an 45-50C° idel  temp without getting any performence in return.

 

I hope someone knows a way to deal with this.

 

Thank you in advance

Outcomes