AnsweredAssumed Answered

Can anyone help with my new Ryzen 3700x not posting?

Question asked by mthenj on Sep 22, 2019
Latest reply on Sep 24, 2019 by elstaci

've been trying to troubleshoot this problem for nearly a month now.

 

I bought a Ryzen 3700x and upgraded it from a Ryzen 5 1400. I updated to the most recent bios before I installed the new part.

 


When powered on my computer will not POST and the CPU debug LED is a solid red.

 


I have tried every compatible BIOS versions, tried to boot with only one ram in every slot, took out the CMOS battery to reset my BIOS. I even bought a new ASRock Phantom gaming 4 because i assumed it was an issue with the MSI MOBO. When my parts are installed into the new ASRock MOBO my system power cycles every 15 seconds with the DRAM and CPU LEDs on. This is also the second 3700x chip i have tried, i returned the first one for replacement but this second one is having the same issue.

 

I am pretty lost right now and help would be greatly appreciated.

Outcomes