AnsweredAssumed Answered

RX580 @ 1440p repeated crashes

Question asked by scr3wballl on Sep 19, 2019
Latest reply on Sep 21, 2019 by mstfbsrn980

I am at my wits end and about to sell this GPU. I built this system less than 7 months ago and have had these problems on and off ever since.

 


    8GB XFX XXX RX580
        GPU temps rarely get over 70C while gaming, GPU has never been overheated or throttled
    Ryzen 5 2600 (stock cooler and speeds, no OC)
        CPU temps rarely go over 65C while gaming, CPU has never been overheated or throttled
    B450M board (ASUS Prime B450M-A/CSM)
    SATA SSD OS drive (Win10 Pro), NVMe drive for games, HDD for long term storage
    700W Gold+ PSU
    DDR4-3200 RAM, default speed for the RAM (not OC), XMPP profile
    HP S240uj 24" 1440@60Hz monitor
    All drivers up to date with Win10 1903 and AMD, and latest BIOS

 


The problem is the games would work fine for a week or two, then every single day for another 2-3 weeks almost every game would crash when used at 1440p resolution for more than 10-15 minutes. This is happening with Cities Skylines, GTAV, AOW: Planetfall, Civ VI, Stellaris, as well as a few others released since 2015 in my library used for testing, none that are "heavy hitters" on the GPU. Now when I drop the resolution to 1080p, I can play for hours on end with no problems, no crashes, but that is not why I bought a 1440 monitor, I should not have to drop resolution just to play any game. As you can see I prefer 1440p on simulation games where framerate is much less important.

 

I started with 16GB DDR4-3200 (2x 8GB, not OC'd) and I thought it was not enough RAM so I bumped it up to 32GB (4x 8GB). Then the games started crashing much more frequently, so I thought I got a bad stick or two of new RAM, but multiple 12+ hours runs of different RAM testing options (like memtest) came back with zero errors. With my 25+ years in IT, I know they are not always accurate so I got the RMA. Installed replacement RAM, crashes are back to the usual 10-15 minutes just like before. I swapped to the new RAM only and same crashes, same timeframe.

 


I swapped to a different B450M board I had for another system and it is the exact same issue. I installed fresh Win10 on a different SSD, installed 1 game and crashes persist. On this fresh install, I removed all traces of AMD drivers, installed my old 2GB nvidia GTX1050Ti, and it can play everything at 1440 without any crashes (of course at reduced framerates for most newer games).

 


So I used this GPU in another older system I have (Core i5-3350P, 16GB DDR3-1600), and with fresh install of 19.9.2 drivers, crashes persist there as well. I have 3 other older GPUs, 1 of them AMD, that do not have this problem.

 


I tried XFX drivers, I tried various 17.x AMD drivers, I tried various 19.x drivers, currently have fresh clean install of 19.9.2 drivers installed, and the crashes persist. The only common denominator is the GPU when used at 1440. I already contacted XFX support and they stated this is a driver issue, and AMD needs to handle it due to no overheating, no crashes in other resolutions, and the stress tests come back working great on everything except 1440p.

I tried 3 different DP cables, no difference. Literally the ONLY common denominator is the GPU.

 


So do I sell it and get an overpriced nvidia 1660, or recognize that this is a bug AMD has no interest in fixing?

Outcomes