alseu

World War Z 5700 XT Vulkan stutter

Discussion created by alseu on Sep 8, 2019
Latest reply on Sep 15, 2019 by shinkojiro

Could please anyone with RX 5700 XT who has WWZ game try to run campaign Tokyo ch.1 or ch.2 on Vulkan api and tell if you experience similar problem?
There are major stutters exclusively on Vulkan api and ONLY during these two missions.
Game runs just fine on DX11 but overall perfomance is lower compared to Vulkan and Fidelity FX effects with Radeon Image Sharpening can't be enabled.
The issue is not presented on a system with intel cpu+pascal gpu and it is replicable, i made a short video about it that was sent to the game developers. The reply was - it is a quite unique one and they will check things on their side. 

 

RX 5700 XT
Ryzen 3600
B450 (latest non beta msi bios)
2*8 DDR4 3600, Infinity fabric 1800mhz
Everthing is installed on sata SSD
Win 10 1903
Chipset driver 1.8.19.0915 
Radeon Settings 19.9.1
All drivers were clean installed after using DDU utility in safe mode
Vsyc, Enchanced sync, VSR are is disabled

I tried to verify game files/complete reinstall to no avail. 


Video : 


0:42 - Tokyo chapter 1 (heavy stutters/lag) Serious freezes (1:34) happen more often in further gameplay
2:40 - New York chapter 1 (no issues, game runs smooth, frametime line is consistent)
4:20 - Tokyo chapter 3 (no issues, game runs smooth, frametime line is consistent)
Video captured by Relive. Issue remains without recording
Framerate capped @141 by RivaTuner statistics server, freesync enabled (i tried to run the game without Msi Afterburner and Riva on and with freesync disabled- it's all the same).
Gpu die temperature, gddr6 tempperature, cpu temperature, frametime line are presented via overlay to show that it's not an overheating issue.

Outcomes