AnsweredAssumed Answered

Blender crashes when using RPR

Question asked by jears on Aug 28, 2019

Whenever I switch to RPR as my render engine and I try using my R9 280x for rendering it works for a few minutes and then it just crashes, the task is completely terminated, no error message, blender just closes. This happens on all scenes when I use my GPU, it doesn't happen when using my CPU. It also hasn't happened to me in the viewport, just in rendered view or during rendering. When executing blender through the command line I get this at the moment of the crash:

I tried running blender as administrator and in compatibility mode, but it still crashes. I also tried reinstalling RPR and uninstalling the material library.

In the attachment is a test file, I just put in a monkey, subdivided it and gave it two materials, which caused it to crash after a few minutes.

In the second file I duplicated the monkeys, which didn't accelerate the crashing, so a more complex scene doesn't seem to affect the crashes

 

System details:

OS: Windows 10 home x64 build 18362

CPU: AMD Ryzen 3 2200G

RAM: 8GB DDR4

GPU: R9 280X 3GB

Graphics Driver: Adrenaline 19.8.1

Running blender 2.8 with RPR addon v2.0.112 (core 1.34.1)

Outcomes