AnsweredAssumed Answered

RX 5700 XT no sound

Question asked by bravosixniner on Aug 27, 2019

I just bought an ASRock Challenger RX 5700 XT. The moment I installed it, it immediately interferes with all audio out on my entire motherboard. I have headset plug into the headset jack on the front of my case and USB powered speakers plugged into audio out on the back. I have tried every single solution suggested on Reddit and the net, nothing works. It's 100% the RX 5700 XT as the moment I unplug it and run my PC with no GPU all audio out immediately works. I plug in my old RTX 2060 and all audio outputs functions perfectly.

 

The moment I plugged in the RX 5700 XT immediately all sound goes out on all audio outputs and is replaced with a very very low ringing sound on all audio out and no sound what so ever from my whatever im doing on the PC.

 

I have checked and made sure mute is not on.

Disabled and re enabled the speakers in the sound settings.

Disabled and re enabled sound card in device manager.

Updated Bios, updated all drivers, especially RealTek drivers.

Checked and made sure HD Audio was enabled in Bios.

Unpluged and replugged in my speakers and headset. Verfied they worked by plugged into laptop and checked on same PC with RTX 2060 and no GPU with no problems at all.

Removed and reinserted GPU several times to rule out that it was loose.

Updated to latest GPU drivers.

Disabled AMD HD audio that comes with drivers.

Re enabled AMD HD audio and swapped to HDMI instead of DP and plugged speakers into monitor.

 

I'm guessing it's either poor quality control and maybe my card isn't grounded well or design flaw as I can trace back issue 100% to RX 5700 XT. As the moment I unplug the RX 5700 XT, no more slight low ringing on speakers and headset and my sound comes back. I plug back in my RTX 2060 and 0 issues.

Outcomes