AnsweredAssumed Answered

Vega 64 Nitro - 19.x.x drivers don't work

Question asked by stefan_s86 on Aug 20, 2019
Latest reply on Sep 8, 2019 by stefan_s86

Hi,

 

as I've found no solution in my reddit thread (https://www.reddit.com/r/AMDHelp/comments/c36wrv/new_vega_64_sapphire_nitro_huge_problems_with/), i will try it here.

 

A few days ago I've installed my new Vega 64 Nitro from Sapphire. Before that my old GPU driver from my Fury Nitro was removed by AMD Cleanup Utility.

 

I've then downloaded an installed newest driver 19.6.2 for this card. Now the trouble began. Everytime I boot up system, after 20 seconds I get black screen (lost signal) and GPU fans go to 100%. System is not responding anymore but still running in background. I had to hard reset PC.

Save mode worked without problems.

 

I've tried a few other 19.x.x drivers like 19.4.1 or 19.3.2 and now the new ones 19.7. and 19.8. Same problems.

Then installed 18.12.2 and it worked. Card runs normal since then regarding heat, performance and so on.

So my question: Does anybody know similiar behaviour`with Vega cards? Were there some new features in the new drivers that can cause such problems? Should I try also the other 19.x.x drivers?

 

I've read there could be problems with new Windows 10 version 1903?!

 

Thanks for your help.

 

My Specs:

- Vega 64 Sapphire Nitro - No OC, but -100mV undervolted

- Ryzen 5 1600 3,6ghz OC

- 16 GB RAM DDDR4 3000mhz

- 500W PSU BeQuiet Pure Power 10 (I know seems a bit low, but no problems so far in stress tests and gaming)

- Windows 10 1903

Outcomes