AnsweredAssumed Answered

qemu upgraded from intel to amd...all file accesses result in 80% cpu usage

Question asked by bash64 on Aug 14, 2019
Latest reply on Aug 15, 2019 by waltc

Hello,

I used an msi gt 70 laptop with i7 4940mx cpu and intel/nvidia integrated graphics for over 5 years.

QEMU ran like a champ. Long story on how I got gpu passthru to run on an optimus board.

At one point I switched to using a 1TB intel ssd to speed up gaming a bit. It worked.

 

Just last month I began building my dream machine.

I am in $3000.

I wanted to render with opencl and cuda and and do gpu passthrough without rebooting into a special ramdisk.

AMD promised me a lot.

 

My specs:

amd threadripper gen 2 12 core, 32gb of ram

msi x399 carbon pro

amd radeon pro duo r9 fury X liquid cooled.

nvidia 980 ti oc.

 

The issues:

I could not passthru the nvidia card so i swapped video cards and passed thru the radeon.

It worked. Installed w7 drivers.

 

The test games are fallout 4 and fallout 76.

They run fine until the game must 'zone' and load more 3d objects and more textures.

That's when the fun begins.

On the linux side my threadripper cpus jump from 20->40% cpu usage to 80% cpu usage and the game lags till I cant even move anymore.

 

This all worked on my old system no issues.

Same qemu. Same virtual hd. Same SSD, but only 4 cores and not 12.

 

I did change my script to remove kvm=off which is for nvidia only.

I was also told that my cpu did not support hyperthreading.

So I changed the -smp line to compensate with 1 socket and so many cores.

 

(I do not use a gui/libvirt ,etc....I have always used a script.)

 

I hope someone out here has some insight as to what is wrong.

 

I do use redhat virtio drivers (scsi and nic). I hope they are not for intel only.

I removed the scsi driver and installed Microsofts driver and it got worse so I put it back in.

 

I am using the last bios made available for my board.

I also use the 'rcu_nocbs=0-23 process.max_cstate=5' kernel boot options to prevent constant crashing in linux.

and, yes, it works quite well.

 

All help appreciated.

 

 

 

Outcomes