blverobot

RX 480 Win10 Freeze

Discussion created by blverobot on Aug 12, 2019
Latest reply on Aug 13, 2019 by mstfbsrn980

Hello fellow humans,

   I'm not a spider and I'm at my wits end here. Around April this year, my pc started locking up. The screen would freeze with the mouse still working but unable to click on anything, music or video is still playing in the background (if I have them running) until the stuff it is reading on RAM runs out and no keyboard input would register. Sometimes the freeze would happen a minute or five after first getting passed through the log screen but I have experienced it freeze as Windows booted (twice) or just as when the log screen came up (once). The freeze would always reset custom wattman settings. Sometimes, the fan would go super Saiyan after these resets when the PC boots but then power down to base form once Win10 starts booting. Rarely would I get a freeze after a few hours of use (only happened once, and only after ten hours).

 

Here are the things I have tried to alleviate this with bare minimal improvement if none at all:

  • tried almost all drivers from 15.x.x to latest using DDU for a clean driver uninstall at safe mode: freeze still happens
  • disabled Win10's fastboot: had it happen where the PC would freeze at the Windows logo after a reboot a couple of times, this fixed that
  • tried amdmatt's suggestion in another RX 480 freezing issue thread from '16 :Windows reports no problems but the pain remains the same (also didn't want to necro the thread as I don't know the rules for that)
  • adjusted wattman power limiter: -50% has reduced the freezing significantly (only once per first boot now if at all), 0 to +50% no difference as far as I can tell
  • checked main drive health: Samsung's software says all's good
  • checked for RAM errors: Windows says it's alright too

 

   Although I've never had it freeze during graphics-intensive gaming, I did have it happen once while playing Stellaris, so I guess it can happen during gaming, I just wasn't unlucky enough yet. I haven't tried reinstalling the OS yet because I have a feeling this thing will freeze during install and screw me over forever.

 

I have a few theory as to why this is happening:

  • latest updates Windows pushed is designed to bully me specifically
  • PSU is starting to croak and is rolling natural 1's a few minutes at fresh boot on the 12v rail
  • ghost of all my vanquished video game enemies is haunting my PC
  • ghost of all my vanquished enemies is haunting me
  • my 2-year-old GPU is about ready to graduate to the landfill

 

Aside from this, I have had zero problems with this card since I bought it so I really hope you guys and gals can help, thanks in advance . I am a normal human and not a spider.

 

Specs

GPU: Sapphire Nitro+ OC 8gb RX 480

CPU: Intel i5-2500 @ 3.30GHz

RAM: Kingston Hyper-X 8GB 1333MHz

MOBO: Asus P8H67-M LE (latest bios)

PSU: Cooler Master GX 650w Bronze (12v rail up to 52A supposedly)

OS: Windows 10 Pro build 18362.239

Outcomes