AnsweredAssumed Answered

RX 480 error 43

Question asked by fidoo001 on Aug 11, 2019
Latest reply on Aug 13, 2019 by mstfbsrn980

Hello. My MSI Gaming X RX 480 is showing error 43 in device manager, when I tried patching using atikmdag patcher I get "No signal" message on monitor after windows logo.
I bought this used GPU for my previous build. When I put it in PC there was error 43. After 2 days of troubleshooting I contacted owner and he sent me link to atikmdag patcher. This solved the problem, GPU was working fine after that. However my CPU died and the GPU was not used for around 3 months. Now in my new build I got error 43 again, used atikmdag patcher and after Windows logo I don't get any signal on DVI. Windows can load normally without patching, with error 43. I tried removing drivers using DDU (in safe mode) and reinstalling drivers, clean Windows install... On our TV it worked using HDMI (no error 43) except terrible stuttering in some games, instant crash while loading Far Cry 3 and random crashing in TF2. While flashing BIOS I get "SubsystemID mismatch" error in new atiwinflash and in old atiwinflash it can't detect my GPU.
Looks like previous owner modded BIOS. Is there anything I can do except RMA my card? Any help is appreciated!

Specs: 
Asus Prime A320M-K motherboard
Ryzen 1600@stock frequency, stock cooler
HyperX 8GB DDR4 2666MHz 
MSI GAMING X RX 480 4GB

Outcomes