AnsweredAssumed Answered

Ryzen Master is still NOT working!!

Question asked by gordon2019 on Aug 3, 2019
Latest reply on Oct 3, 2019 by captainunderunderpants

Hello!

 

First my system is:

CPU: Ryzen 7 2700X

RAM: G.Skill Ripjaws V F4-3600C16D-16GVK

MOBO: AsRock Fatal1ty X370 Professional Gaming

GPU: EVGA GeForce GTX 1080 Ti SC Black Edition GAMING iCX

OS: Windows 10 64bit v1903 (no insider program)

BIOS: Latest version 5.30

DRIVERS: Everything is up to date and the latest version!!!!!! Including the chipset drivers! Except for RM...

 

So, I download all Ryzen Master programs from my CPU's driver page. So it has to work on MY SYSTEM, right?

Well, it's not working!! Nothing works anymore!

 

The last working version of RM is 1.4.0, and it's from ages ago..........................................

Versions 1.5.0, 1.5.1, 1.5.3, 2.0.0, 2.0.1, none of them work!!! Nor through install, nor through 1.4.0's update!

And all of them give the same stupid error message: "a newer version is already installed"..........

It wasn't working even before the update to Windows 10 v1903.

 

-I uninstalled the old one and tried clean install. Not working.

-I deleted every registry and folder on my system related to Ryzen Master. Not working.

-I used the Windows 10 Install/Uninstall Troubleshooter tool. Not working!

-I used the AMD uninstall everything tool. Still not working!!!

 

Why is it NOT WORKING??? What did you do? In god's name, FIX IT!!

People are complaining about this error since version 1.5.0!!!! How the hell you did not fix it yet???

 

FIX  IT,  PLEASE!!!!!!!!!!!!!!!!

Outcomes