AnsweredAssumed Answered

3700X boost issues persist

Question asked by cheezeartz on Aug 4, 2019
Latest reply on Dec 1, 2019 by naman_4130
Hey guys,
 
so I was very excited that the new chipset drivers where released.
Apparently, they fixed the boosting issues for a lot of people, however for me personally, they still exist.
If any of you could help me, I would be very thankful...
 
First of all, my setup:
AMD Ryzen 7 3700X under a Be Quiet! Dark Rock 4
MSI X470 Gaming Pro Carbon with BIOS Version 7B78v29 with AMD ComboPI1.0.0.3ab
16GB DDR4 3200 CL 16
Palit GeForce RTX 2070 Super JS
 
Software:
Windows 10 build 1903
latest chipset drivers from july 31st
latest ryzen master
ryzen balanced power plan
 
Now to my issues:
 
As stated above, my CPU refuses to boost properly. (images below)
 
To start of with Cinebench Multiscore, I get a max. all core boost to 4.075 Mhz, sometimes 4.1 Ghz.
This results to a score which is basically my CPU at stock when compared to all the reviews.
 
The real issue is my single core boosting behaviour, because it is REALLY weird.
One core boosts properly to about 4.2 Ghz, which is not that high all by itsels, however it drops down every few seconds to under 3 Ghz, stays there for a moment and goes back up to just over 4 Ghz.
This results in a terrible single core score with on average 460 points.
 
To demonstrate that this problem still exists in Games, I loaded up GTA V in 800x600 to show you that I only get around 90 FPS, with my cores not really boosting all that high.
 
My temps are all in Check, so where do I have my mistake?
 
I really appreciate your help guys!
 
Screenshots:

Outcomes