AnsweredAssumed Answered

[resolved] Ryzen 3700 on X470 and Radeon rx 5700 xt - video, sound over HDMI problems

Question asked by fazerxlo on Aug 1, 2019
Latest reply on Aug 6, 2019 by shump

Unfortunately currently I cannot fully use my new setup because of graphic card issues and sound problems over HDMI.

 

PRIME X470-PRO
Gigabyte Radeon RX 5700XT
AMD Ryzen 3700X

[Memory vendor/model/specification]
Various tested:
Goodram Play 2666 2x8gb
Partiot Viper 3733 2x8gb


Latest version of windows 10 all updates, various versions of drivers from amd website also tested latest drivers from asus product page.

The problem is with the main board to properly support radeon card.
1) with the previous bios 4804 card is almost working the problem is with disturbed hdmi sound and frequently video driver is reloading (from the event log) and random computer restarts, also I couldn't use
2) with the latest bios 5007 and pcie 1 x16 the card is working with very limited performance, no info about temperature fan speed load etc. Cannot use Wattman at all. There is almost no sound over hdmi.
3) with the latest bios 5007 and different pci 2 x8 slot the card is working almost perfect beside sound from time to time the sound is disturbed, and very sporadic computer restarts. This setup I currently use.

I found on reddit that some of people have this problem: https://www.reddit.com/r/Amd/comments/cdzwwo/asus_bios_updates_and_ryzen_3000/

 

And some other post similar to mine:

 



But I want to let you know.

I did test on asus B350 prime ryzen 1600 and the same video card and everything work perfect. I wapped radeon to nvidia 1070 and also run smoothly.

Outcomes