leuse

AMD Radeon RX 5700 XT not recognised, causing crashes when updating?

Discussion created by leuse on Aug 1, 2019
Latest reply on Aug 21, 2019 by electric.tom

Hello,


I bought a brand new config :

MSI x570 Gaming Edge Motherboard

Ryzen 8 CPU

AMD Radeon RX 5700 XT GPU

I took my old HDD and SSD (which I already formatted)

I added a brand new M2

2 DDR4 8Go Ram 3000Mhz

650W PSU (I took the one from my old computer)

I installed a brand new Windows 10

 

I built this all up and it booted just fine

 

When I boot the computer it works fine. The 4 LEDs on the MB goes on & off like it should

When I look onto the Device Manager my GPU is not here, it says it's running the defaut ATI windows graphics

 

When I try to update the list of Devices it crashes

When I try to update the AMD driver (which I don't have any installed at the moment) it crashes

 

I flashed my BIOS to the last version available on MSI website (it went from 1.0 to 1.2)

 

When I look into my computer, my graphic card has the Radeon logo red glowing, the fan is spinning and the HDMI port on the GPU is working since I can see my monitor display what it's supposed to

 

I tried running this in safe mode, I tried switching PCI 1.0 port to GEN3 and then GEN4

 

I don't know what to do to make it so my computer "recognises" the GPU... Any help?

Thanks in advance

Outcomes