AnsweredAssumed Answered

Ryzen 9 3900x linux (thermal?) problems

Question asked by dllu on Jul 22, 2019
Latest reply on Jul 27, 2019 by mcalin

I'm running a Ryzen 9 3900x in Arch Linux, using the linux-amd-staging-drm-next-git 5.3.839842.40cc64619a25-1 kernel.

I am seeing some anomalous behaviour:

  • All cores are constantly running at 4.0 GHz even when idle, as seen by running `watch "cat /proc/cpuinfo | grep MHz"`.
  • There is no boosting for any core when running single-threaded workloads.
  • Computer shuts off after running all cores on maximum load for about 5 to 10 minutes. Frequency does not seem to throttle down under high load, it keeps running at 4.0 GHz until it turns off. The workload is compilation (compiling LLVM).
  • There is no way to monitor CPU temperatures in Linux.

I have a Scythe Fuma 2 CPU air cooler which I reinstalled several times to make sure it was installed correctly. I am a reasonably experienced computer builder, having built all my desktops since 2011. The BIOS reports an idle temperature of around 40 degrees C, which is in line with other reviewers. My room temperature is around 20 to 25 degrees C.

 

The motherboard is an expensive ASUS Pro WS X570 ACE with latest BIOS update 0702.

 

I have tried with two different power supplies, a Seasonic Focus Plus 750 W Gold and an EVGA SuperNova 850 P2 Platinum, with the same results. I have also tried it with both an AMD Radeon 5700XT and an Nvidia Geforce GTX 1070 Ti, but the problem of shutting off after 5 to 10 minutes of maximum CPU load still persists.

Outcomes