cencen16

UPDATE: (direct3d related) AMD Radeon HD 7400m is detected but does not work 

Discussion created by cencen16 on Jul 15, 2019

Hi,

 

Yesterday did i reinstall windows 10 on my laptop. Everything was working fine, but i wanted to make a clean install before i went on vacation. (last install of windows was 6 months ago when i upgraded to SSD).

 

After installing windows and all games and programs, i started Mortal Kombat 9 on steam and it worked fine. Afther that i tried to open Battlefield 4 (which Always worked fine on my laptop on low settings), but i got an error saying: intel HD 3000 does not support direct x 10. But i already have directx 12 installed.

 

I reinstalled windows 10 a few times. I deleted and reinstalled amd driver a couple times, and still the same error.

 

I uninstalled AMD again and tried to play Battlefield 4, and it really started the game on intel HD 3000 graphics. Very slow but it just did. So My laptop detects the AMD graphics, but when i start a game it does not see or start with it. I tried to use the settings in switchable graphics but still no change.

 

Does anybody know what I can do else?

 

PS:

I tried installing 3 diffrent versions of amd driver, and same error with every version.

 

UPDATE: direct3d related

I ran a bench test on my laptop and i got this error:

 

Laptop Specs:

HP Pavilion DV7-6b01ed (build 2011)

Windows 10 home 64bits

kingston SSD a400

Memory 12gb

Intel i5-2430m 2,40ghz

Intel HD 3000 graphics + Radeon HD 7400M

 

Outcomes