AnsweredAssumed Answered

Acer 5 AMD Radeon - Games not using dedicated GPU

Question asked by f3li4s on Jul 14, 2019
Latest reply on Jul 27, 2019 by matthew998

After spending hours on this problem we decided to ask for help on this forum.
Steps that we have been taking so far:

 

1.When the laptop arrived, vendor claimed that all drivers are pre-installed by AMD. However, we did not find ‘AMD Radeon Settings’ App installed on the system and games where lagging, while we can see in Task Manager that only the Vega is running on 100% while the RX560 was on 0%.

 

2.We installed AMD Radeon Settings and entered all programs that we want to run on RX560 in the GAMES tab, then we went to System tab--> Switchable Graphics and set all games and programs to run on ‘High Performance’.

 

3.We tried running Minecraft and can see that RADEON SETTINGS says it’s running on RX560X, but the Task Manager is telling us that RX560 runs on 0% and Vega runs on 100%.

 

4.We thought it would be good to make a clean re-install. So, we download AMD Clean Uninstall Utility from the page AMD Clean Uninstall Utility and ran it. After cleaning we installed the latest driver from AMD website (https://www.amd.com/en/support Graphics-->Radeon 500 Series-->Radeon RX 500X Series-->Radeon RX 560X). The driver was called: Adrenalin 2019 Edition 19.7.1 Optional.

 

5.However, running Minecraft didn’t deliver any different results. It was still using the Vega instead of RX 560X.

 

6.In another blogpost (https://community.amd.com/thread/229263) we found that Minecraft is a OpenGL application that cannot use dedicated graphics and only uses integrated graphics. So, we tried the same with Far Cry, but the exact same problem happens.

 

Honestly, we are quite clueless now and hope you can advise us how to motivate software to run on the dedicated card and not on the integrated.

Thanks a lot!

 

System Specs:
Model: Acer Nitro 5 (AN515-42-R5GT)
Processor: AMD Ryzen 5 2500U (quad-core processor, up to 3.6GHz)
Graphics: AMD Radeon Vega 8 Mobile
Dedicated Graphics: AMD Radeon RX 560X with 4 GB of dedicated GDDR5 VRAM.
Memory: 8GB DDR4
OS: Windows 10 Home (64bit)

Outcomes