AnsweredAssumed Answered

Installing Linux on the  Acer Aspire 3 A315-41

Question asked by rchambel on Jul 12, 2019

Since i have bought a Acer Aspire 3 A315-41-R3DQ with the Ryzen 5 2500u and Vega 8 a couple of weeks ago that i am trying to install linux on the machine but i have nothing but problems. Making a long story short:

 

First i tried to make a usb disk with the Limpus OS that came with the computer but got me a differ file error. Then i tried running a live Ubuntu 19.04 from usb and everything worked fine (with the "pci=noacpi" parameter in grub) but when i tried installing to the HDD the GRUB couldn't save the settings and the installation aborted. I updated the bios to the latest version (1.13) but the GRUB problem continued and the touchpad stop working. Since Limpus is based on Fedora i tried Fedora 30 Workstation and managed to install it to computer but very often i got a "BUG: soft lockup - CPU#02 stuck for 23s" error and can't start Fedora.

 

I've been using linux for quite some time but i'm just a user with very little technical knowledge. Now i'm running windows 10 on the Aspire but i really would love to run linux exclusively on the computer. Every help is much appreciated.

Outcomes